RaQuestについて

ページ位置:

RaQuestについて

RaQuestはモデリングツールEnterprise Architectとの連携を念頭に置いて開発された要求管理ツールです。

要求管理ツールとは、システムやアプリケーションの開発時に存在する要求を効率的に管理し、要求の変更や実装漏れなどにすばやく対応することで、確実な開発を支援するためのツールです。

RaQuestはEnterprise Architectと連携し要求管理を行います。Enterprise Architect自身でも要求管理のための機能はある程度備えられていますが、RaQuestでは要求を効率よく管理することができます。また、要求を一覧として表示・印刷したり、HTMLやWordドキュメントとして出力したりすることもできます。これにより、Enterprise Architectの機能を拡張して、要求管理を行うことができます。

さらに、RaQuestで作成した要求項目をユースケースとして生成したり、ユースケースを要求項目として読み込んだりすることもできます。これにより、要求管理からユースケース図などの他の図へと効率よく連携させることができます。

なお、RaQuestとは、Requirements Adjustment Quest という単語から作成した造語であり、「ラクエスト」と発音します。「ラク」には「楽」という意味もあり、簡単に楽しく要求管理ができるようなツール、という願いも込められています。


注意事項・制限事項

ページ位置: RaQuestについて >

注意事項・制限事項

WARNING RaQuest バージョン6.0 日本語版を実行するためには、Enterprise Architect 日本語版 バージョン15.0 以降のバージョンがインストールされていることが必要です。

WARNING RaQuest バージョン6.0 日本語版は、Windows 11・Windows 10・Windows Server 2022・Windows Server 2019・Windows Server 2016 (各日本語版・各最新のサービスパック適用済み）で動作確認しております。それ以外の環境での動作は保証しておりません。

WARNING フローティングライセンスのライセンスマネージャーは1.3以降のバージョンが必要です。

WARNING 組み合わせる Enterprise Architect のエディションにより、一部機能に制限があります。詳細はEnterprise Architect エディションによるRaQuestの動作の差異をご確認ください。


サポートと要望等

ページ位置: RaQuestについて >

サポートと要望等

サポート有効期間中のお客様は、サポートを利用することができます。現在、すべてのサポートはネットワークを通じて利用することができます。頂いたご連絡に対しては、できるだけ早く回答し、RaQuestに反映させていきたいと考えております。

RaQuestの利用者が効率的に、そして効果的に作業を進められるように、スパークスシステムズ ジャパンは常に気を配っています。それゆえ、この製品に関することや文書・インストール手順などについての、どんな提案やフィードバック・コメントも私たちは重要であると考えています。

下記URLより、ご質問・コメント・要望等をご連絡ください。

https://www.sparxsystems.jp/support_form.htm?RaQuest

また、電子メールを利用して連絡することも可能です。アドレスはsupport@sparxsystems.jpです。

これまでサポートにお寄せ頂きましたご質問の一部は、スパークスシステムズ ジャパン フォーラムで確認することができます。


RaQuestを起動する

ページ位置: RaQuestを利用する >

RaQuestを起動する

RaQuestを起動するには、デスクトップのアイコンをダブルクリックするか、スタートメニューから呼び出してください。

初回起動時には、以下のようなダイアログが表示され、ライセンスキーを入力する必要があります。ご購入時に受け取ったRaQuestのライセンスキーを入力してください。

WARNING 新しいバージョン（ビルド）をインストール後、ライセンス認証の画面が表示される場合があります。このような場合、購入時ではなく更新時の最新のライセンスキーを入力してください。

フローティングライセンスの場合には上記ダイアログでフローティングにチェックを入れ、OKボタンを押してください。下記のようなダイアログが表示され、RaQuest のフローティングライセンスのキーを取得する必要があります。追加・更新ボタンを押し、共有キーの取得タブでキーファイルの位置と製品を選択してください。詳細はEnterprise Architect ドキュメント ライブラリのフローティングライセンス マニュアル等をご覧ください。

ライセンス認証が完了すると、次のような画面が表示されます。

WARNING 起動時にエラーや空白のメッセージボックスが表示される場合には、必要なファイルが不足しているか、あるいは正しくインストールされていない場合がほとんどです。インストーラを利用して適切にインストールしてください。

起動後には、希望するプロジェクトファイルを開くか、またはサーバリポジトリに接続をして、作業を開始してください。なお、以前に利用したファイルや接続については、最大4つまでメインメニュー ->「ファイル」の中に項目として表示され、簡単に呼び出すことができます。


Enterprise ArchitectからRaQuestを呼び出す

ページ位置: RaQuestを利用する >

Enterprise ArchitectからRaQuestを呼び出す

Enterprise ArchitectからRaQuestを呼び出すためには、ツールとして登録すると効率的です。登録方法の手順は次の通りです。

1.Enterprise Architectを起動し、ホーム | 設定 | オプション | カスタマイズ を選択します。

2.ツールのタブを選択し、ボタンを押して項目を追加します。名前にはRaQuestなど適当な名前を、コマンドにはRaQuest.exeへのフルパスを指定します。

3.引数の欄には"$f"と入力します(すべて半角・"(ダブルクォート)も必要)。既定のディレクトリは空欄で構いません。

これにより、プロジェクト | 独自に追加したツール | RaQuest を選択すると、現在開いているプロジェクトをRaQuestで開いて利用することができるようになります。


サンプルプロジェクト

ページ位置: RaQuestを利用する >

サンプルプロジェクト

RaQuestには、サンプルとして利用できるプロジェクトファイルが添付されています。このサンプルを利用することで、RaQuest全体の大枠をつかめるのではないかと思います。

サンプルプロジェクトファイルは、RaQuestのメインメニュー ->「ヘルプ」->「サンプルプロジェクト」で開くことができます。サンプルプロジェクトを開くと、以下のようなサンプルが表示されます。

(表示オプションの設定により、下記の画面と異なるスタイルでの表示になる場合があります)

まずは、このファイルを利用して、概要を把握してみてください。なお、このサンプルを利用した機能ガイドを提供していますので、あわせてご覧ください。また、スタートアップマニュアルも提供していますので、最初の利用時にはぜひご利用ください。

·機能ガイド

·スタートアップマニュアル


新しいプロジェクトファイルを作成

ページ位置:

新しいプロジェクトファイルを作成

新しいプロジェクトファイルを作成する方法は2つあります。

1.空の新しいプロジェクトファイルの作成

プロジェクトオプションがすべてデフォルト値

2.ベースプロジェクトを元に新しいプロジェクトファイルの作成

プロジェクトオプションやパッケージ構成にベースプロジェクトの設定を利用

1. 空の新しいプロジェクトファイルの作成

以下の流れで新しいプロジェクトファイルを作ってください。

RaQuestを起動し、メインメニュー ->「ファイル」->「新規プロジェクト」を選択

新しいプロジェクトファイルの名前を入力

（SysMLデータプロジェクトの新しいプロジェクトの場合は、ファイルの種類で「SysMLベースファイルqeaxファイル」もしくは「SysMLベースeapxファイル」を選択）

下図のように空のプロジェクトファイルができます。

INFO ログインユーザ名の設定や、要求の状態や種類を設定しておくと便利です。設定方法は以下の項目を参照してください。

·ユーザ名の確認・設定

·要求の種類の設定

·要求の状態の設定

·要求カテゴリの設定

2. ベースプロジェクトを元に新しいプロジェクトファイルの作成

以下の流れで新しいプロジェクトファイルを作ってください。

RaQuestを起動し、メインメニュー ->「ファイル」->「ベースプロジェクトのコピー」を選択

新しいプロジェクトファイルのパスとベースファイルのパスを設定

下図のようにベースプロジェクトをコピーした新しいプロジェクトファイルができます。

(ベースプロジェクトに「要望・要件・仕様」のパッケージが登録されていた場合）

INFO ログインユーザ名や、要求の状態や種類の設定を確認してください。確認方法は以下の項目を参照してください。

·ユーザ名の確認・設定

·要求の種類の設定

·要求の状態の設定

·要求カテゴリの設定


ユーザ名の確認・設定

ページ位置: 新しいプロジェクトファイルを作成 >

ユーザ名の確認・設定

RaQuestでは、要求を変更した場合や、承認した場合などに操作を行ったユーザ名が記録されます。このユーザ名の設定はEnterprise Architectと共通になっています。取得できない場合は、Windows のログイン名を利用します。

カレントユーザ名が取得できなかった場合には、「ログインユーザー名の取得に失敗しました。」のダイアログをプロジェクトを読み込むときに表示します。

カレントユーザ名は次のようにして確認・設定します。

1.メインメニュー ->「ツール」->「ローカルオプション」を選択(下図)

2.既定のユーザ名に、ユーザ名を設定

3.OKボタンを押下後、RaQuestを再起動（同時にEnterprise Architectを起動している場合、Enterprise Architectを含め再起動）

プロジェクトファイルに、上記で指定した「名前」と同じ名前の担当者を作成しておくと便利です。作成は、担当者ツリーに切り替え、部署を右クリックすると表示されるコンテキストメニューで行うことができます。

75 (メニュー) 76 (登録後)

WARNING Enterprise Architectでプロジェクトファイルのセキュリティを有効にしている場合は、上記で設定した「既定のユーザ名」ではなく、ログインユーザの「姓」と「名」を半角スペースでつなげた名前がユーザ名として使われます。この場合も現在のユーザ名をカレントユーザ名の欄で確認できます。また、「姓」と「名」を半角スペースでつなげた名前を、プロジェクトファイルに担当者として作成しておくと便利です。

WARNING Enterprise Architectでプロジェクトファイルのセキュリティを有効にした場合の、ユーザの設定に関しては Enterprise Architectとの連携 - ログインユーザ名を参照してください。


要求の種類の設定

ページ位置: 新しいプロジェクトファイルを作成 >

要求の種類の設定

要求には「機能」「性能」「操作性」などの種類があります。これらの種類の選択肢を設定し、利用することができます。選択肢はEnterprise Architectと共通です。

種類の設定方法は、プロジェクトファイルを開き、メインメニュー ->「ツール」->「プロジェクトオプション」を選択し、「要求の種類」タブを選択します。

新しい種類を設定する場合は、新規ボタンを押下後、種類や説明等を入力し、保存ボタンを押下してください。更新の場合は、一覧から該当の行を選択し、編集後、保存ボタンを押下してください。

INFO ここで指定した値は後で変更することもできます。

INFO 『「EAの追加の要求要素」の種類を追加』ボタンで、EAの要求図のツールボックスの「追加の要求要素」にある要素に対応する要求の種類を追加できます。（機能要求・ビジネス要求・ユーザー要求・非機能要求・アーキテクチャ要求・実装要求・規制制約・セキュリティ要求）

INFO 「SysMLベースファイルを使用」をオンにして新規作成した場合（SysMLデータプロジェクト）は、以下が初期設定になります。


要求の状態の設定

ページ位置: 新しいプロジェクトファイルを作成 >

要求の状態の設定

要求には、いくつかの状態があります。既定値では、たとえば「承認済」「設計中」などがあります。これらの状態は、独自の状態を定義して利用することができます。選択肢はEnterprise Architectと共通です。

状態の設定方法は、プロジェクトファイルを開き、メインメニュー ->「ツール」->「プロジェクトオプション」を選択し、「要求の状態」タブを選択します。

新しい状態を設定する場合は、新規ボタンを押下後、状態や説明等を入力し、保存ボタンを押下してください。更新の場合は、一覧から該当の行を選択し、編集後、保存ボタンを押下してください。

RaQuest では要求管理の流れを想定しているため、「検討中」「検討済」「承認済」を定義し「状態と初期値」のタブで「状態の既定値」「検討済みを示す状態」「承認済みを示す状態」をそれぞれの値に合わせて定義してください。

INFO ここで指定した値は後で変更することもできます。


要求カテゴリの設定

ページ位置: 新しいプロジェクトファイルを作成 >

要求カテゴリの設定

要求には「要望」「要件」「仕様」などや「ビジネス要求」「ステークホルダー要求」「ソリューション要求」「移行要求」など、抽象度で分類することがあります。これらの分類（RaQuestにおいては要求カテゴリと呼ぶ）の選択肢を設定し、利用することができます。要求カテゴリの選択は、Enterprise Architectにおいての要素の種類の指定になります。

要求カテゴリの設定方法は、プロジェクトファイルを開き、メインメニュー ->「ツール」->「プロジェクトオプション」を選択し、「要求カテゴリ」タブを選択します。

新しい要求カテゴリを設定する場合は、新規ボタンを押下後、要求カテゴリ名やアイコン等を入力し、保存ボタンを押下してください。更新の場合は、一覧から該当の行を選択し、編集後、保存ボタンを押下してください。

INFO ここで指定した値は後で変更することもできます。

WARNING 要求カテゴリの設定可能な数に制限はありませんが、新規要求作成のメニューには15個までしか表示されません。


EAのプロジェクトファイルをRaQuestで利用する

ページ位置:

Enterprise ArchitectのプロジェクトファイルをRaQuestで利用する

Enterprise ArchitectのプロジェクトファイルをRaQuestで利用する場合、以下の流れでRaQuestの設定を行ってください。

1.プロジェクトファイルの指定

2.パッケージの指定

3.SysMLデータプロジェクトの指定

4.必須オプションの指定


プロジェクトファイルの指定

ページ位置: EAのプロジェクトをRaQuestで利用 >

プロジェクトファイルの指定

Enterprise ArchitectのプロジェクトファイルをRaQuestで利用する場合は、既存のプロジェクトファイル(QEAX,EAPX)を、RaQuest のメインメニュー ->「ファイル」->「開く」から表示される、下記の画面で指定します。

既存のプロジェクトファイル(QEAX,EAPX)がない場合は、新しいプロジェクトファイルを作成にしたがって作成するか、Enterprise Architectで新しいプロジェクトファイル(QEAX,EAPX)を作成し、RaQuest で開いてください。

初めてEnterprise Architectのプロジェクトファイル(QEAX,EAPX)を読み込ませた場合は、パッケージの指定に進みます。


パッケージの指定

ページ位置: EAのプロジェクトをRaQuestで利用 >

パッケージの指定

初めてEnterprise Architectのプロジェクトファイル(QEAX,EAPX)を読み込ませた場合は、「指定したプロジェクトにはRaQuestの情報がありません。」というメッセージが表示されます。ここで「はい」を選択することで、RaQuestで扱うパッケージの指定を行います。この指定を行わないと、プロジェクトファイルをRaQuestで利用することはできません。

次のようなダイアログでパッケージの指定を行います。このダイアログでは、「新規追加」ボタンを押すことで、新規にパッケージを作成することもできます。

Enterprise Architectのプロジェクトファイル(QEAX,EAPX)を初めて開いたときのパッケージの指定時は、要求パッケージを指定すると、パッケージの指定の設定が完了します。

続いてSysMLデータプロジェクトの指定に進みます。

RaQuestで利用するパッケージには、次の2種類があります。

·要求パッケージ
要求パッケージは、RaQuestで作成する要求項目を保管するためのパッケージです。それぞれの要求項目は、このパッケージの中にEnterprise Architectの要求要素として保管されます。

·ユースケースパッケージ
ユースケースパッケージは、要求要素と同期させるユースケースを生成・保管するためのパッケージです。「ユースケースの生成」や「ユースケースからの読み込み」機能を利用する際等に指定することができます。

INFO 指定した要求パッケージとユースケースパッケージの位置は後でオプションで変更することもできます。


SysMLデータプロジェクトの指定

ページ位置: EAのプロジェクトをRaQuestで利用 >

SysMLデータプロジェクトの指定

SysMLデータプロジェクトに指定するか確認します。要求をSysMLの要求とする場合は「はい」を選んでください。

SysMLデータプロジェクトにおける動作は、SysMLデータプロジェクトをご覧ください。

WARNING 一旦SysMLデータプロジェクトに指定すると、戻すことはできません。後からSysMLデータプロジェクトに変換することは可能です。

続いて必須オプションの指定に進みます。


必須オプションの指定

ページ位置: EAのプロジェクトをRaQuestで利用 >

必須オプションの指定

プロジェクトファイルを開くとき、「状態の既定値」「検討済みを示す状態」「承認済みを示す状態」「種類の既定値」が定義されていなかった場合、RaQuestの要求管理の流れで想定している状態の指定のために、次のようなダイアログが開く場合があります。この状態と初期値設定ダイアログで「状態の既定値」「検討済みを示す状態」「承認済みを示す状態」「種類の既定値」を設定します。

INFO ここで指定した値は後で変更することもできます。


注意点

ページ位置: EAのプロジェクトをRaQuestで利用 >

注意点

WARNING RaQuestで一度開いたプロジェクトファイルには、Enterprise Architectで開くと「RaQuest」という名前のモデルルートパッケージが作成されています。パッケージの中には設定情報が含まれていますので、パッケージを削除したり、移動したり、名前を変更しないでください。これらを実行した場合の動作は保証されません。


要求の状態遷移

ページ位置: RaQuestの要求管理 >

要求の状態遷移

RaQuestでは、要求を次のような状態遷移（状態の変更の流れ）で管理することを想定しています。

「初期状態」「その他の状態」「検討済み」「承認済み」の状態の具体的な名前はすべてカスタマイズ可能です。新規作成したプロジェクトの標準状態では以下のようになっています。「その他の状態」はプロジェクトごとに"要調査"など必要なものを追加してください。

·「初期状態」："未検討"

·「その他の状態」："検討中" "保留" "対象外" "重複"

·「検討済み」："検討済"

·「承認済み」："承認済"

作成した要求は、すべて左上の「初期状態」になります。要求の検討状況に応じて、プロジェクトごとに定義される「その他の状態」に変更してください。

これらの状態は、すべて大きく分けると「作業中」の状態になります。これ以外に、RaQuestで明確に定義されている状態として、「検討済み」「承認済み」の状態があります。これらの状態は、検討が完了して、要求の内容が固まった状況を示します。

先ほどの「作業中」に分類される状態から、要求のプロパティダイアログ(後述)で「検討済み」に変更すると、要求項目がロックされて変更できなくなります。

「検討済み」の状態で、「承認」作業を行うと、「承認済み」になり、要求が確定したことを示します。「承認」作業は、「検討済み」以外の状態の要求に対しては行うことができません。

「検討済み」や「承認済み」の状態でロックを解除して再度編集しようとした場合には、確認のダイアログが表示されます。

ここでロックを解除すると、その要求は「初期状態」に戻ります。また、その要求に依存しているすべての要求は、「再検討が必要」のフラグがある状態になります。「再検討が必要」である要求は、「関係図」機能を利用することで、図で把握することができます。


画面概要

ページ位置: 画面概要 >

画面概要

RaQuestの画面は、大きく左右に分かれています。

表示オプションの「要求を常に表示」を選択すると、大きく３つに分けられて表示します。


左側(ツリー表示)

ページ位置: 画面概要 >

左側(ツリー表示)

左側(ツリー表示)はタブ形式で表示されます。プロジェクトの要求の情報と、担当者の情報が含まれています。

プロジェクト

プロジェクトタブには、管理する対象となる要求と、複数の要求をまとめるためのパッケージが階層構造をもって配置されます。パッケージには複数の要求や別のパッケージを階層的に配置することができます。また、要求の下には子要求として、別の要求項目を配置することもできます。要求の下にも分類のためにパッケージを配置することはできますが、移動することはできません。

担当者

担当者タブには、このプロジェクトファイルで定義される担当者と、担当者をまとめるための部署が含まれます。部署の中には、階層的に別の部署を配置することができます。部署や担当者を右クリックすることで、名前を変更したり、位置を変更したり、削除したりすることができます。

新規に担当者や部署を追加する場合には、親となる部署(パッケージ)を右クリックしてください。

種類別・状態別・要求カテゴリ別・影響先・影響元・カスタム

81 （種類別） 82 （状態別） 142 （要求カテゴリ別） 150 （影響先） 151 （影響元） 83 （カスタム）

メインメニュー ->「ツリー」のメニューから項目を選ぶことで、種類別ツリー・状態別ツリー・要求カテゴリ別ツリー・影響先ツリー・影響元ツリー・カスタムツリーのタブが追加され、表示されます。

不要のタブを閉じる場合には、タブを右クリックして「閉じる」を選択してください。タブの数が多くなった場合には、画面にタブが入りきらなくなりますので、必要に応じてタブ表示領域を左右にスクロールさせてください。「すべて閉じる」を選択すると、すべての一覧をまとめて閉じることができます。また、CTRL+Wキーでカレントタブを閉じます。


右側(一覧表示)

ページ位置: 画面概要 >

右側(一覧表示)

右側(一覧表示)には、起動時には一覧形式で要求項目が表示されます。この右側のウインドウもタブ形式になっていますが、タブの個数はユーザーの操作により変化します。一覧を表示すると、タブが追加され、その一覧が表示されます。

不要のタブを閉じる場合には、右上の×ボタンをクリックするか、タブを右クリックして「閉じる」を選択してください。タブの数が多くなった場合には、画面にタブが入りきらなくなりますので、必要に応じてタブ表示領域を左右にスクロールさせてください。「すべて閉じる」を選択すると、すべての一覧をまとめて閉じることができます。また、CTRL+Wキーでカレントタブを閉じます。

右上のコンボボックスで表示一覧項目名を選択することで、表示している一覧の項目を切り替えることができます。表示一覧項目の設定はプロジェクトオプション - 一覧項目もしくはローカルオプション - 一覧項目で設定します。

それぞれの一覧は、一番上に表示されているヘッダーの部分をクリックすることで、その項目でソートすることができます。

一覧において、直接編集可能な項目は、その項目をクリック（「要求を常に表示」オプションがオンの場合は、ダブルクリック）で、編集またはドロップダウンリストで直接変更することができます。

要求の一覧の項目は、通常は黒色での表示となりますが、以下の場合には色がついて表示されます。この色は設定で変更することができます。

·期限切れしている項目：赤

·状態が「承認済み」にあたる状態の場合：灰色

·状態が「検討済み」にあたる状態の場合：青

·再検討が必要な場合：緑

資料の一覧の項目は、通常は黒色での表示となりますが、以下の場合には色がついて表示されます。この色は変更することはできません。

·資料登録した日時よりもファイルの更新日時が新しい場合


右下(要求プロパティ表示)

ページ位置: 画面概要 >

右下(要求プロパティ表示)

表示オプションの「要求を常に表示」にチェックを入れておくと、リストや一覧で選択した要求のプロパティが右下に表示されます。起動時には新規要求入力画面が表示されます。

表示内容については要求のプロパティを参照してください。

この画面の中では以下のショートカットキーが有効です。

·CTRL+TAB(次のタブへ)

·CTRL+SHIFT+TAB(前のタブへ)

·CTRL+U(更新)

·CTRL+N(新規)


一覧

ページ位置: 画面詳細 >

一覧

一覧の内容

下記の一覧を表示します。一覧として表示することで要求の全体の把握を行います。

·要求の一覧

o要求一覧

o変更要求一覧

oTODO要求一覧

o担当なし要求一覧

o要再検討要求一覧

o承認待ち要求一覧

o優先度値順表示

o更新履歴

·パッケージ一覧

·担当要求一覧

·関連の一覧

o要求間関連の一覧

o影響先要求一覧

o影響元要求一覧

·要求の付属要素の一覧

oUML要素一覧

o資料一覧

o割り当て済み担当者一覧

oテスト項目一覧

oコメント一覧

一覧の表示項目の内容はオプションで変更が可能です。

一覧の操作

ソート

一覧では、見出しの部分をクリックすることで、一覧の内容をソートすることができます。ソートされた状態でさらにクリックすると、最初のソートと逆順でのソートになります。

ソートされた状態で、別の見出しをクリックすることで、さらにソートを行うことができます。たとえば、優先度でソートした後に状態でソートを行いますと、状態でソートされ、同じ状態の中では優先度順にソートされた状態になります。

印刷機能を実行する場合には、表示されている内容の順番で印刷されますので、事前にソートしておくと便利な場合があるかと思います。

ダブルクリック

要求のプロパティダイアログを表示します。（「要求を常に表示」オプションがオンの場合は、右下の要求プロパティ部分に表示します。）

チェックボックス

下で説明する右クリックのメニュー（コンテキストメニュー）と右ドラッグ＆ドロップの操作の時に、複数の要求を対象に操作する場合の、対象を選択します。この選択は、一覧の1つのタブの中だけで有効です。1つの要求にチェックボックスのチェックを入れたとしても、他のタブの一覧の同じ要求のチェックボックスの状態には、影響しません

右クリック

次のメニューが表示されます。

44 | 136
(チェックボックスに選択が1つも無い場合) | (チェックボックスに1つでも選択がある場合)

·複数選択

o属性編集
チェックボックスで選択されている要求の属性をまとめて編集します。

o要求カテゴリ変更
チェックボックスで選択されている要求の要求カテゴリをまとめて変更します。

o削除
チェックボックスで選択されている要求をまとめて削除します。

·プロパティ
選択されている要求のプロパティを表示します。

·要求カテゴリ変更
選択されている要求の要求カテゴリを変更します。

·承認
選択されている要求を承認します。

·ツリー内の位置を表示
選択されている要求のツリー内の位置を表示します。

·新規パッケージ・新規要求・新規変更要求
新規にパッケージ・要求・変更要求を追加します。作成されたパッケージ・要求・変更要求は、選択されている要求の子要素となります。

·詳細検索
検索ダイアログを表示します。

·一覧フィルタ
一覧フィルタダイアログを表示します。

·影響先要求一覧
選択されている要求が変更された場合に、連鎖的に変更が及ぶ可能性のある要求を一覧で表示します。

·影響元要求一覧
要求が変更された場合に、選択されている要求にも変更の必要性が生じるような要求を一覧で表示します。

·要求の関係を図示
指定した要求と他の要求間の関係を図として表示します。詳細は関係図をご覧ください。

·関係の削除
要求間に定義済みの関係を削除することができます。次のようなダイアログが表示されます。 45

·削除
選択されている要求を削除します。

一覧タブを閉じる

右上の×ボタンをクリックするか、一覧タブで右クリックすると表示されるメニューから、一覧を閉じることができます。すべて閉じることもできます。

ドラッグ＆ドロップ

一覧内でドラッグ＆ドロップを行うと、要素間に関係を作成します。対象の要素がドラッグした要素に依存する(ドラッグ先の要素に変更があった場合には、ドラッグ中の要素にも影響がある)関係が作成されます。ドラッグ＆ドロップした結果はステータスバーに表示されます。

表示一覧項目(属性)の設定

右上のコンボボックスで表示一覧項目名を選択することで、表示している一覧の項目を切り替えることができます。表示一覧項目の設定はプロジェクトオプション - 一覧項目もしくは ローカルオプション - 一覧項目で設定します。


プロジェクトツリー

ページ位置: 画面詳細 >

プロジェクトツリー

プロジェクトツリーの表示内容

要望、システム要求、詳細要求のようなツリー構造で、要求を表示します。それぞれの要求をパッケージに格納することも可能です。また、要求の子要素としてパッケージを作成し子要求をカテゴリ分けすることも可能です。

プロジェクトツリーの操作

ドラッグ＆ドロップ

ツリー内で要求やパッケージをドラッグ＆ドロップすると、次のような操作になります。ドラッグ＆ドロップした結果はステータスバーに表示されます。

·要求を要求にドラッグ＆ドロップ
ドラッグ先の要素の子要素として対象の要素を移動します。オプション設定によっては、このときに対象の要素がドラッグした要素に依存する(ドラッグした要素に変更があった場合には、対象の要素にも影響がある)関係が作成されます。

·要求をパッケージにドラッグ＆ドロップ
対象の要素をドラッグしたパッケージの中に移動します。

·パッケージを要求にドラッグ＆ドロップ
何もおきません。無効な操作です。

·パッケージをパッケージにドラッグ＆ドロップ
対象のパッケージをドラッグしたパッケージの中に移動します。

·要求を要求に右ドラッグ＆ドロップ
「移動」又は「関連作成」が行えます。

·要求をパッケージに右ドラッグ＆ドロップ
「移動」が行えます。

·パッケージを要求に右ドラッグ＆ドロップ
何もおきません。無効な操作です。

·パッケージをパッケージに右ドラッグ＆ドロップ
「移動」が行えます。

ダブルクリック

要求やパッケージのプロパティダイアログを表示します。（「要求を常に表示」オプションがオンの場合は、右下の要求プロパティ部分に表示します。）オプションでパッケージのダブルクリックは、配下項目の展開に変更が可能です。

右クリック

次のメニューが表示されます。

41 (要求) 42 (パッケージ)

·プロパティ
選択されている項目のプロパティを表示します。

·新規パッケージ・新規要求・新規変更要求
新規にパッケージや要求を追加します。選択されている項目の子要素になります。

·要求一覧
選択されている項目配下の要求一覧を表示します。

·影響先要求一覧
選択されている要求が変更された場合に、連鎖的に変更が及ぶ可能性のある要求を一覧で表示します。

·影響元要求一覧
要求が変更された場合に、選択されている要求にも変更の必要性が生じるような要求を一覧で表示します。

·要求の関係を図示
指定した要求と他の要求間の関係を図として表示します。詳細は関係図をご覧ください。

·すべて展開・すべて折りたたむ
選択している項目の配下をすべて展開あるいは隠します。

·上へ・下へ(CTRL+UP/DOWN)
ツリー内の位置を上あるいは下に移動します。

·削除
選択されている項目を削除します。

·状態数の表示
選択されているパッケージの状態数を表示します。


担当者ツリー

ページ位置: 画面詳細 >

担当者ツリー

担当者ツリーの内容

担当者と部署のツリーを表示します。

Enterprise Architectのログインユーザ名を同一の担当者名の担当者を作成しておくと、コメントの記入時などに自動的に現在のログインユーザ名をデフォルトとして設定し便利に使用可能です。

担当者ツリーの操作

ドラッグ＆ドロップ

担当者あるいは部署の位置を移動します。ドラッグ先は部署である必要があります。ドラッグ＆ドロップした結果はステータスバーに表示されます。

右クリック

次のメニューが表示されます。

·名前を変更
選択されている担当者や部署の名前を変更します。

·担当者の追加・部署の追加
担当者や部署を追加します。部署(パッケージ)が選択されている必要があります。

·担当要求一覧
メインメニュー ->「一覧」->「担当要求一覧」と同じ機能です。

·すべて展開・すべて折りたたむ
選択している項目の配下をすべて展開あるいは隠します。

·上へ・下へ(CTRL+UP/DOWN)
選択されている項目をツリーの上あるいは下に移動します。

·削除
選択されている部署や担当者を削除します。


種類別・状態別・要求カテゴリ別・カスタムツリー

ページ位置: 画面詳細 >

種類別・状態別・要求カテゴリ別・カスタムツリー

種類別・状態別・要求カテゴリ別・カスタムツリーの内容

種類別ツリーは、要求の種類毎のツリーを表示します。

状態別ツリーは、要求のバージョンと状態の組み合わせでツリーを表示します。

要求カテゴリ別ツリーは、要求カテゴリ毎のツリーを表示します。

カスタムツリーは、ユーザが指定した2つまでの属性の組み合わせでツリーを表示します。

それぞれ、全体の要求の状態などを把握するために使用することが可能です。

種類別・状態別・要求カテゴリ別・カスタムツリーの操作

ドラッグ＆ドロップ

ツリー内では要求のパッケージへのドラッグ＆ドロップのみ可能です。パッケージのドラッグ＆ドロップはできません。要求をパッケージへドラッグ＆ドロップすると、次のような操作になります。ドラッグ＆ドロップした結果が失敗した場合ダイアログが表示されます。

·要求をパッケージにドラッグ
対象の要求をドラッグした属性値に変更し、移動します。

ダブルクリック

要求のプロパティダイアログを表示します。

右クリック

次のメニューが表示されます。

87 (要求) 86 (パッケージ)

·プロパティ
選択されている項目のプロパティを表示します。

·影響先要求一覧
選択されている要求が変更された場合に、連鎖的に変更が及ぶ可能性のある要求を一覧で表示します。

·影響元要求一覧
要求が変更された場合に、選択されている要求にも変更の必要性が生じるような要求を一覧で表示します。

·要求の関係を図示
指定した要求と他の要求間の関係を図として表示します。詳細は関係図をご覧ください。

·要求一覧
選択されている属性値を持っている要求一覧を表示します。

·すべて展開・すべて折りたたむ
選択している項目の配下をすべて展開あるいは隠します。


影響先・影響元ツリー

ページ位置: 画面詳細 >

影響先・影響元ツリー

影響先・影響元ツリーの内容

影響先ツリーは、要求の影響先の要求をツリー表示します。

影響元ツリーは、要求の影響元の要求をツリー表示します。

影響先ツリーの場合は、影響元要求が複数存在する場合・影響元ツリーの場合は、影響先要求が複数存在する場合、それぞれ同一要求の複数表示を行います。

全体の要求の関係を把握するために使用することが可能な表示です。

以下の関係図のように関連が循環している場合、以下のようなツリー表示になります。循環で再度表示される要求のアイコンの右上に赤丸を表示します。

153 関係図 154 影響先

影響先・影響元ツリーの操作

ドラッグ＆ドロップ

ドラッグ＆ドロップはできません。

ダブルクリック

要求のプロパティダイアログを表示します。

右クリック

次のメニューが表示されます。

·プロパティ
選択されている項目のプロパティを表示します。

·新規要求(現ビルドでは未提供機能)
選択されている項目の影響先・影響元要求として新規要求を作成します。

·影響先要求一覧
選択されている要求が変更された場合に、連鎖的に変更が及ぶ可能性のある要求を一覧で表示します。

·影響元要求一覧
要求が変更された場合に、選択されている要求にも変更の必要性が生じるような要求を一覧で表示します。

·要求の関係を図示
指定した要求と他の要求間の関係を図として表示します。詳細は関係図をご覧ください。


ツリーと一覧の連携操作

ページ位置: 画面詳細 >

ツリーと一覧の連携操作

ドラッグ＆ドロップ

ツリーと一覧の間でドラッグ＆ドロップした結果はステータスバーに表示されます。

·要求を要求にドラッグ＆ドロップ
要素間に関係を作成します。「ドラッグした要素がドロップした要素に依存する」(ドラッグ先の要素に変更があった場合には、ドラッグ中の要素にも影響がある)関係が作成されます。

·担当者を要求にドラッグ・要求を担当者にドラッグ
対象の要求に担当者を割り当てます。

·一覧の要求をSHIFTを押しながらツリーのパッケージにドラッグ＆ドロップ
対象の要求をパッケージに移動します。

·それ以外の場合
何も変更されません。

右ドラッグ＆ドロップ

一覧からプロジェクトツリーへの右ドラッグ＆ドロップが有効です。ドロップしたときにメニューを表示します。

·複数関連作成
一覧でチェックした要求とドロップした要求の間に関係を作成します。

·複数移動
一覧でチェックした要求をドロップした要求またはパッケージに移動します。

·関連作成
ドラッグした要求とドロップした要求間に関係を作成します。

·移動
ドラッグした要求をドロップした要求またはパッケージに移動します。

同じ要求の選択

ローカルオプション 表示2タブの「ツリーと一覧で同じ要求を選択」をチェックしておくと、常に同じ要求が選択された状態になります。


マトリックス表示

ページ位置: 画面詳細 >

マトリックス表示

要求と要求間・要求とユースケース間などの関係は多対多の関係が成立します。関係を設定する場合や、作成した要求と既存の関係を確認・作成する場合には、マトリックス形式での表示・操作が便利です。

下記のような関係のマトリックス表示を行えます。

·要求と要求間

·要求と担当者間

·要求とユースケース間

·要求とUML要素間

再検討が必要な関係の表示： 155

以下のような操作が可能です。

·対象のパッケージ
対象となる関係の種類ならびにパッケージを指定します。

·要求・担当者・ユースケース・UML要素
対象となる関係の要素

o上側の表示
表示する要求のパッケージ（ボタンで選択を行う）

o下側の表示
表示する対象となる関係の要素のパッケージ（ボタンで選択を行う）

oフィルタボタン
表示する対象となる要求のフィルタ条件

oコンボボックス
表示する対象となる関係の要素の絞り込み

·関連無しを色付
関連が一つもない行または列を色付します。（上のチェックボックスが行・下のチェックボックスが列）

·更新ボタン
表示対象や色付け設定を変更した後に押下することで、マトリックス表示を更新します。

·CSV出力ボタン
表示しているマトリックス表示を、CSVファイルとして出力します。

·RTF出力ボタン
表示しているマトリックス表示を、RTFファイルとして出力します。

·閉じるボタン
マトリックス表示を閉じます。

·セルのダブルクリック
関係がない場合は関係の作成、関係がある場合は、関係の方向の変更または削除を行います。

·列のタイトルのクリック
クリックした列のデータで行のソートを行います。

·マトリックス上での右クリック
選択しているセルにより以下のいずれかのメニューを表示します。

111 オプションメニュー 114 関係の作成または削除メニュー
オプションメニューで「区切り可変」をオンに設定することで、ヘッダ行の幅や高さを変更できるようになり、要求の概要の表示量を変更できます。


メニュー項目の詳細

ページ位置:

メニュー項目の詳細

ここでは、RaQuestで利用可能な機能の詳細について説明しています。メインメニューの順序に沿って説明されています。

·ファイル

·編集

·表示

·検索

·プロジェクト

·ツリー

·一覧

·マトリックス

·要求

·ツール

·ヘルプ


ファイル メニュー

ページ位置: メニュー項目の詳細 >

ファイル メニュー

·新規プロジェクト
新しいプロジェクトファイル（QEAX,EAPX）を作成し、開きます。

·ベースプロジェクトのコピー
ベースファイルをコピーして、新しいプロジェクトファイルを作成し、開きます。

·開く
プロジェクトファイルを開きます。既存のプロジェクトファイルを指定してください。Enterprise Architectのプロジェクトファイル（QEAX,EAPX）を開くことも可能です。

·サーバリポジトリに接続
Enterprise Architectのサーバリポジトリに接続します。この項目を選択すると、次のようなダイアログが表示されますので、接続文字列を入力します。あるいは、Enterprise Architectで以前にサーバリポジトリを開いたことがある場合には、コンボボックスに接続文字列が設定されていますので、その値を利用することもできます。
29

サーバリポジトリへの接続文字列を取得する方法は、次の手順で行うことができます。

1.Enterprise Architectを起動して、サーバリポジトリを開く。

(スタートページの「最近利用したプロジェクト」に表示されるようにする)

2.Enterprise Architectの「Enterprise Architectのアイコン」->「プロジェクトを開く」を選択する。

3.「最近利用したプロジェクト」の一覧から、該当のサーバリポジトリを選択する。

4.右クリックメニューの「パスの編集」を選択

5.表示された接続文字列ダイアログの「値の入力」欄に文字列が表示されます。これが、サーバリポジトリに接続するための文字列になります。

6.文字列をすべて選択して、クリップボードにコピーする。

7.RaQuestを起動し、「サーバリポジトリへの接続」ダイアログに貼り付ける。一度起動すると、RaQuestのファイルメニューに登録されますので、以降はその項目を選択するだけで開くことができます。

·閉じる
現在開いているプロジェクトファイルを閉じます。プロジェクトファイルを閉じるときに、オプションの設定内容が保存されます。

·再読み込み
現在開いているプロジェクトファイルをいったん閉じ、再度開きます。これにより、複数人数でプロジェクトファイルを利用している場合に、最新の状態に反映することができます。
また、いくつかのオプション項目は「再読み込み」することによって反映されます。

·印刷
現在表示している一覧を印刷します。(現在のRaQuestでは、一覧以外は印刷対象外です。）印刷対象の一覧を選択後、この機能を実行してください。印刷される内容は、表示されている一覧の内容そのままとなりますので、必要に応じてソートやフィルタを実行後、印刷機能を呼び出してください。
(注：対象の一覧のタブをクリックしてから機能を呼び出してください)

·印刷プレビュー
印刷を行う前にプレビュー画面で確認することができます。
(注：対象の一覧のタブをクリックしてから機能を呼び出してください)

·印刷設定
プリンタに関する設定を行います。

·インポート
インポート機能では、外部ファイルから要求項目の情報を読み込み、追加することができます。追加される位置は、機能を呼び出すときに選択されているパッケージになります。

oCSV
CSV形式のファイル(拡張子.csv)を読み込むことができます。CSVファイルの項目の並び順は指定可能です。要求IDまたはGUIDが同一の要求がある場合は上書きすることが可能です。

·エクスポート
エクスポート機能は、外部ファイルへ指定された形式で要求項目の情報を出力する機能です。

oHTML
HTML形式のファイル(拡張子 .htm)へ出力することができます。出力形式は固定です。

oRTF
RTF形式のファイル(拡張子 .rtf)へ出力することができます。出力フォーマットはEnterprise Architectのドキュメントのテンプレートエディタでカスタマイズ可能です。

oCSV
CSV形式のファイル(拡張子.csv)へ出力することができます。出力形式は指定可能です。

oExcel
Excel形式のファイル(拡張子 .xlsx)へ出力することができます。この機能を実行する場合には、対象のマシンにMicrosoft Excelがインストールされている必要があります。

·関係ファイルをまとめる
要求が資料として保持しているファイルを、指定したディレクトリにすべてコピーします。これにより、情報を持ち出したりする場合に、出力されたディレクトリのみをコピーすればよいことになります。
なお、URLの場合にはファイルは生成されませんが、リンク(Windows標準のショートカット形式のファイル)が生成されます。
オプションとして、将来的にはRaQuestで保持しているファイルパス情報を出力先に一括変更する機能も提供予定です。

·終了
RaQuestを終了します。


編集 メニュー

ページ位置: メニュー項目の詳細 >

編集 メニュー

·コピー
一覧あるいはツリーで選択した要求をコピーします。コピーした要素は「貼り付け」機能で利用することができます。

·切り取り
一覧あるいはツリーで選択した要求を切り取ります。貼り付けを選択した後、対象の要求は削除されます(貼り付けた位置に移動します)。

·貼り付け
コピーあるいは切り取りをした要求を貼り付けます。ツリーで選択されている要素がパッケージの場合には、そのパッケージの中の末尾に配置されます。要求の場合にはその要求の子要求となります。

一覧で「貼り付け」を行うことはできません。

·削除
一覧あるいはツリーで選択されている要求を削除します。
オプションで削除可能になっていない場合には、削除することはできません。
オプションで削除時に確認になっている場合には、確認のダイアログが表示されます。


表示 メニュー

ページ位置: メニュー項目の詳細 >

表示 メニュー

·ツールバー
画面上部のツールバーの表示の有無を設定します。

·ステータスバー
画面下部のステータスバーの表示の有無を設定します。

·ツリーツールボタン
ツリー画面上部のツールボタンの表示の有無を設定します。

·一覧ツールボタン
一覧画面上部のツールボタンの表示の有無を設定します。


検索 メニュー

ページ位置: メニュー項目の詳細 >

検索 メニュー

·詳細検索
現在表示されている一覧で、指定した条件に一致する要求にカーソルを移動します。
63

·前方検索
直前に詳細検索した条件で現在のカーソル位置から前方検索を行います。

·後方検索
直前に詳細検索した条件で現在のカーソル位置から後方検索を行います。

·一覧フィルタ
現在表示されている一覧で、指定した条件に一致しない項目を削除して表示します。
フィルタは複数回適用させることもできますので、フィルタを行った結果にさらに適用することもできます。(ただし、フィルタする前の結果に戻すことはできません)また「新しいタブで実行」ボタンでフィルタ結果を新しいタブで開きます。

33

現在表示されている一覧がUML要素一覧・資料一覧・割り当て済み担当者一覧・テスト項目一覧・コメント一覧の場合は以下の対応するダイアログが表示されます。

109 UML要素一覧

125 資料一覧

126 割り当て済み担当者一覧

129 テスト項目一覧

127 コメント一覧

·置換
すべての要求（またはパッケージ）に対して、指定された条件で置換を行います。
115
オプションは現ビルドでは未提供機能になります。

·ツリーから検索
ツリーから指定された条件で検索を行い、結果を一覧表示します。
64


プロジェクト メニュー

ページ位置: メニュー項目の詳細 >

プロジェクト メニュー

·ベースラインの管理
ベースラインに関する操作を行うための、ベースラインの管理ダイアログを開きます。詳細はベースラインの管理をご覧ください。

·用語集
用語集ダイアログを表示し、用語を編集することができます。

·セキュリティ

oユーザ切り替え
ログインユーザを切り替えます。

oパスワードの変更(現ビルドでは未提供機能)
現在のログインユーザのパスワードを変更します。

·状態のカウント

o現在の状態数の表示
現在定義されている要求項目について、さまざまな項目による要求項目の個数を表示します。
56

o過去の一覧のCSV出力
測定した項目数をCSV形式で出力します。

·ID重複チェック
既存の要求のIDで重複しているものがないかどうか確認します。文字列としてチェックします。


ツリー メニュー

ページ位置: メニュー項目の詳細 >

ツリー メニュー

·プロジェクトツリー
プロジェクトツリーを表示します。

·担当者ツリー
担当者ツリーを表示します。

·種類別ツリー
種類別ツリーを表示します。

·状態別ツリー
状態別ツリーを表示します。バージョンと状態の組み合わせで表示されます。

·要求カテゴリ別ツリー
要求カテゴリ別ツリーを表示します。

·影響先ツリー
影響先ツリーを表示します。

·影響元ツリー
影響元ツリーを表示します。

·カスタムツリー
カスタムツリーを表示します。
下図が表示され任意の属性を指定できます。ユーザ定義属性を指定することも可能です。10件までメニューに登録することが可能です。
95
(「該当要求がなくても表示」チェックボックスは、種類などの列挙型の時に選択できます。通常は、その属性の値を持つ要求がない場合は、その属性の値のパッケージを表示しません。チェックが入っていると、その属性の値を持つ要求がない場合でも、ツリーにその属性の値のパッケージを表示します。）


一覧 メニュー

ページ位置: メニュー項目の詳細 >

一覧 メニュー

ツリーで選択されている要素とその要素以下の要素を対象に一覧を表示します。

·要求一覧
要求一覧を表示します。

·変更要求一覧
変更要求の一覧を表示します。

·TODO要求一覧
未完了の要求(検討済みでも承認済みでもない要求）が一覧で表示されます。

·担当なし要求一覧
担当者が指定されていない要求の一覧を表示します。

·要再検討要求一覧
要再検討の属性にチェックが入っている要求の一覧を表示します。

·承認待ち要求一覧
承認待ちの要求が一覧で表示されます。
この一覧は、承認者が一括で承認を行う場合に便利です。この一覧の要求を選択後、メインメニュー ->「要求」->「承認」(個別)を実行することで承認を行うことができます。

·優先度値順表示
検討中の要求に対して、優先度などのパラメータを考慮して計算された優先度値を含む一覧を表示します。
優先度値はプロジェクトオプションの動作2の優先度値計算式を使い計算します。

·更新履歴
更新履歴の一覧を表示します。

·パッケージ一覧
パッケージの一覧を表示します。この一覧は、常にプロジェクト全体のパッケージを対象にして一覧を表示します。

·担当要求一覧
指定した担当者が担当する要求の一覧を表示します。画面左側「担当者」タブから、対象の担当者を指定した後、この一覧を表示させることができます。

·要求間関連一覧
要求と要求の関連の一覧を表示します。

·影響先要求一覧
選択されている要求が変更された場合に、連鎖的に変更が及ぶ可能性のある要求を一覧で表示します。

·影響元要求一覧
要求が変更された場合に、選択されている要求にも変更の必要性が生じるような要求を一覧で表示します。

·UML要素一覧
要求に関連づけたUML要素の一覧を表示します。

·資料一覧
要求の資料の一覧を表示します。

·割り当て済み担当者一覧
要求に割り当て済みの担当者一覧を表示します。

·テスト項目一覧
要求のテスト項目の一覧を表示します。

·コメント一覧
要求のコメントの一覧を表示します。

一覧表示の内容や操作の説明は一覧をご覧ください。


マトリックス メニュー

ページ位置: メニュー項目の詳細 >

マトリックス メニュー

·マトリックス
マトリックス画面を表示します。

·要求間マトリックス
要求間の関係をマトリックス形式で表示することができます。また、マトリックスから要求間の関係を追加したり、削除したりすることができます。

·要求-担当者マトリックス
要求と担当者間の関係をマトリックス形式で表示することができます。また、マトリックスから要求に担当者を割り当てたり、担当をはずしたりすることができます。

·要求-ユースケースマトリックス
要求とユースケース間の関係をマトリックス形式で表示することができます。また、マトリックスから要求とユースケースの関係を追加したり、削除したりすることができます。ユースケースパッケージの指定がない場合、パッケージ指定のダイアログが表示されます。

·要求-UML要素マトリックス
要求とUML要素間の関係をマトリックス形式で表示することができます。また、マトリックスから要求とUML要素の関係を追加したり、削除したりすることができます。

表示されたマトリックスダイアログの説明はマトリックス表示をご覧ください。


要求 メニュー

ページ位置: メニュー項目の詳細 >

要求 メニュー

·複数要求属性編集
チェックした複数の要求の属性をまとめて編集するための別ウィンドウを表示します。

·複数要求カテゴリ変更
チェックした複数の要求のカテゴリをまとめて変更するための別ウィンドウを表示します。

·複数要求削除
チェックした複数の要求をまとめて削除します。

·プロパティ
要求のプロパティをウィンドウで表示します。必要に応じて、要求のプロパティを変更することもできます。

·要求カテゴリ変更
要求カテゴリ変更のウィンドウを表示します。

·新規パッケージ
新規にパッケージを作成します。パッケージを作成する場合には、親となるパッケージをツリーで選択している必要があります。

·新規要求
新規に要求を作成します。ツリーで選択されているパッケージや要求の下に作成されます。

·新規変更要求
新規に変更要求を作成します。選択されている要求の変更要求として作成されます。

·新規コメント
新規にコメントを追加します。ツリーや一覧で選択されている要求に追加します。

·承認
ツリーや一覧で選択されている要求を承認します。承認するためには、要求項目が「検討済」になっていなければなりません。実行すると、次のようなダイアログが表示されます。
36

·要求間の制約を設定(現ビルドでは未提供機能)
複数の要求間に制約条件を指定します。制約条件とは、たとえば、ある要求が有効である場合に自動的に有効になる要求(強い関係を持つ要求)や、ある要求が有効である場合には無効になる要求(排他関係にある要求)などを設定します。

·関係の設定(現ビルドでは未提供機能)
複数の要求間に関係を設定します。関係がある要求とは、ある要求に変更があった場合にその影響を受ける要求を示します。現在のバージョンは関係の設定はドラッグ＆ドロップでのみ可能です。

·要求の関係を図示
指定した要求と他の要求間の関係を図として表示します。詳細は関係図をご覧ください。


ツール メニュー

ページ位置: メニュー項目の詳細 >

ツール メニュー

·Enterprise Architectを起動
Enterprise Architectを起動し、現在開いているプロジェクトファイルを読み込みます。

·Enterprise Architect連携

o要求からユースケースを生成
要求パッケージと同じ構成で、ユースケースを生成します。ユースケースの生成場所は、ユースケースパッケージになります。

o用語集からクラスを生成
用語集の項目と同名のクラスを生成することができます。

o現在のプロジェクトから読み込み

§ユースケースから要求の生成
ユースケースパッケージと同じ構成で、要求を生成します。

§要素の内部要求の読み込み
Enterprise Architectの要素のプロパティダイアログ内にある「要求」タブに定義されている内容を要求として読み込みます。このときに、オプション設定でこのタブに定義されている要求情報をEnterprise Architectの要求要素として変換することもできます。

o他のプロジェクトから読み込み

§要求(現ビルドでは未提供機能)
他のプロジェクトファイルから要求要素を一括で読み込みます。

§ユースケース(現ビルドでは未提供機能)
他のプロジェクトファイルからユースケースを一括で読み込み、同名の要求項目を生成します。
読み込む場所は選択されているパッケージになります。

·動作ログ取得ツールを起動
動作ログ取得ツールを起動し、今後のRaQuestの動作ログを表示します。

·プロジェクトオプション
プロジェクト毎に設定が可能なオプション項目を変更します。プロジェクトオプションはこのプロジェクトのすべてのユーザに有効です。項目の詳細はこのヘルプの「プロジェクトオプション」をご覧ください。

·ローカルオプション
ローカルユーザ毎に設定が可能なオプション項目を変更します。ローカルオプションは設定したユーザが扱うすべてのプロジェクトファイルに有効です。項目の詳細はこのヘルプの「ローカルオプション」をご覧ください。


ヘルプ メニュー

ページ位置: メニュー項目の詳細 >

ヘルプ メニュー

·RaQuestについて
RaQuestのバージョン情報を表示します。現在入力されているライセンスキー等の情報も表示されます。

·更新ライセンスキーの入力
更新ライセンスキーの入力を行います。

·ヘルプ
RaQuestのヘルプファイル（このファイル）を表示します。

·サンプルプロジェクトを開く
サンプルプロジェクトを開きます。

·RaQuestのWebサイトの表示
スパークスシステムズジャパンのRaQuestのwebサイトを表示します。

·最新ビルドの確認
RaQuestの最新ビルドがあるかどうか確認するためのwebページを表示します。


要求のプロパティ

ページ位置:

要求のプロパティ

要求のプロパティには以下の二つの表示形式があります。

·要求の内容を「概要」「詳細」「ユーザ定義属性」の3タブで表示する形式

·要求の内容を「説明」「属性」の2タブで表示する形式

デフォルトは、「概要」「詳細」「ユーザ定義属性」の3タブで表示する形式ですが、ローカルオプションの表示1タブの「属性を一覧形式で表示」にチェックを入れるか、プロジェクトオプションの動作1タブの「このプロジェクトでは、属性を一覧形式で表示」にチェックが入ったプロジェクトを開くと、「説明」「属性」の2タブで表示する形式に変更されます。プロジェクトの複数言語が有効になっている場合は、複数言語対応のページをご確認ください。

「概要」「詳細」「ユーザ定義属性」の3タブ形式の表示例

「説明」「属性」の2タブ形式の表示例

要求のプロパティ表示詳細

要求のプロパティには、次の項目を表示します。

·「概要」タブ

·「詳細」タブ

·「ユーザ定義属性」タブ

·「説明」タブ

·「属性」タブ

·「UML要素」タブ

·「資料」タブ

·「担当者」タブ

·「テスト項目」タブ

·「コメント」タブ

·「再検討」タブ

·「更新履歴」タブ

それぞれの表示形式では以下のタブが表示されます。なお、要求や変更要求の新規作成時には、"*"印がついたタブのみ表示されます。

·「概要」「詳細」「ユーザ定義属性」の3タブ形式

o「概要」タブ*

o「詳細」タブ*

o「ユーザ定義属性」タブ*

o「UML要素」タブ

o「資料」タブ

o「担当者」タブ

o「テスト項目」タブ

o「コメント」タブ

o「再検討」タブ

o「更新履歴」タブ

·「説明」「属性」の2タブ形式

o「説明」タブ*

o「属性」タブ*

o「UML要素」タブ

o「資料」タブ

o「担当者」タブ

o「テスト項目」タブ

o「コメント」タブ

o「再検討」タブ

o「更新履歴」タブ

他のRaQuestで同時に同じ要求の要求詳細ダイアログが開かれている場合はロック状態になります。このロックは外すことができますが、ロックを外した場合の要求の属性の値がどのようになるかは保障されません。

コーポレート版以上のEnterprise Architectを使用しセキュリティの有効化をしてある場合に、別のユーザが同時に同じ要求の要求詳細ダイアログが開かれている場合は、ロックを含めたすべての属性が編集不可能になる、排他ロックが行われます。

また、すべての項目に共通のボタンやチェックボックスがダイアログの最下部にあります。

·OK
変更を保存してダイアログを閉じます。

·キャンセル
変更を破棄してダイアログを閉じます。

·上
一覧において、現在表示されている要求の上にある要求の内容を表示します。

·下
一覧において、現在表示されている要求の下にある要求の内容を表示します。

·変更元要求
要求が変更要求の場合に、変更元になっている要求の情報を表示します。

·適用
ダイアログを閉じずに、変更内容を保存します。複数の要求の内容を続けて変更していきたい場合、このボタンで更新後、上下ボタンで別の要求を表示し、効率よく内容を変更していくことができます。

·連続作成
変更内容を保存し、新たな新規要求画面になります。このボタンで、新しい要求を次々と入力が可能になります。

ダイアログの大きさの変更も可能です。

この画面の中では以下のショートカットキーが有効です。

·CTRL+TAB(次のタブへ)

·CTRL+SHIFT+TAB(前のタブへ)


「概要」タブ

ページ位置: 要求のプロパティ >

「概要」タブ

要求の概要や状態の設定・参照、リビジョンや登録日時の参照タブです。「概要」「詳細」「ユーザ定義属性」の3タブ形式の時に表示されます。

·概要
要求の概要です。簡潔でわかりやすい説明を入力します。

·別名
要求の別名です。ローカルオプションの表示1タブの「別名を概要・説明タブに表示」により非表示になります。

·ID
要求を一意にするIDです。ローカルオプションの状態と初期値タブの「自動でID番号付加」の設定により手動で設定することもできます。

·リビジョン
要求の現在のリビジョン番号です。自動的に入力され、編集することはできません。

·バージョン
要求が関連するバージョンです。

·フェーズ
要求が関連するフェーズです。

·期限
要求に対して何らかの処理をする期限です。「期限」のチェックを選択することで、設定できます。

·種類
要求の種類を指定します。プロジェクトオプションの「要求の種類」で選択肢を変更できます。

·状態
要求の現在の状態を指定します。プロジェクトオプションの「要求の状態」で選択肢を変更できます。

·ロック
要求のプロパティを変更できないようにするためにロックを行うことができます。同時に他のRaQuestで要求詳細ダイアログが開かれている場合もロック状態になります。このロックは外すことができますが、その場合の要求の属性の値がどのようになるかは保障されません。

·再検討が必要
依存する要求が、「検討済」あるいは「承認済」になったあとに変更された場合に、このチェックボックスにチェックが入ります。要求の状態が検討済みに変更されると自動的にチェックが外されます。

·承認済み・承認者
要求が承認者によって承認されていることを示します。このチェックボックスは操作することはできません。要求を「承認」するためには、メインメニュー ->「承認」機能を利用する必要があります。

·登録日時
要求が最初に登録された日時です。自動的に入力され、編集することはできません。

·登録者
要求を最初に登録した人の名前です。自動的に入力され、編集することはできません。

·最終更新日時
要求が最後に更新された日時です。自動的に入力され、編集することはできません。

·最終更新者
要求を最後に更新した人の名前です。自動的に入力され、編集することはできません。


「詳細」タブ

ページ位置: 要求のプロパティ >

「詳細」タブ

要求の詳細を文章で入力し、優先度などを設定・参照するタブです。「概要」「詳細」「ユーザ定義属性」の3タブ形式の時に表示されます。

文章だけで表せない要求の詳細は別アプリケーションやEnterprise Architectで作成し「資料」タブを使用し関連付けてください。

·詳細
要求の詳細情報を入力します。改行して複数行にわたって入力することができます。入力ボックスの上のボタンやコンテキストメニューを利用して装飾することも可能です。
「フォント設定」ボタンと「表の挿入」ボタンの利用には、プロジェクトオプションの動作1タブの「要求の詳細欄で拡張書式を利用」の設定が必要です。

·優先度
要求の相対的な優先度です。高・普通・低で指定します。

·難易度
要求の相対的な難易度です。高・普通・低で指定します。

·リスク
要求に潜在するリスクが問題化する可能性です。高・普通・低で指定します。「高」の場合には、その要求内容が対象の設計開発において、今後問題となる可能性が高いことを示します。

·作業量
要求の作業量を数値で指定します。単位は特にありませんので、プロジェクトに応じて決めるか、あるいは相対的な値を入力します。

·安定度
要求内容が変更される可能性について高・普通・低で指定します。「高」の場合には、その要求内容が今後変更される可能性がほとんどないことを示します。

·優先度値
要求の計算された優先度値を表示します。計算式は、プロジェクトオプションの動作2タブで設定します。

·キーワード
要求のキーワードを入力します。


「ユーザ定義属性」タブ

ページ位置: 要求のプロパティ >

「ユーザ定義属性」タブ

ユーザが オプション設定 - ユーザ定義属性 で定義した属性の値を設定・参照するタブです。「概要」「詳細」「ユーザ定義属性」の3タブ形式の時に表示されます。

·属性
属性名と属性値が表になっています。変更できない属性の場合は、属性値の背景のみが灰色になります。

WARNING 属性値の変更は、他の属性名や属性値をクリックするまで反映されません。


「説明」タブ

ページ位置: 要求のプロパティ >

「説明」タブ

要求の概要と詳細の設定・参照タブです。「説明」「属性」の2タブ形式の時に表示されます。

·概要
要求の概要です。簡潔でわかりやすい説明を入力します。

·別名
要求の別名です。ローカルオプションの表示1タブの「別名を概要・説明タブに表示」により非表示になります。

·詳細
要求の詳細情報を入力します。改行して複数行にわたって入力することができます。入力ボックスの上のボタンやコンテキストメニューを利用して装飾することも可能です。
「フォント設定」ボタンと「表の挿入」ボタンの利用には、プロジェクトオプションの動作1タブの「要求の詳細欄で拡張書式を利用」の設定が必要です。

INFO 複数言語を有効にしたプロジェクトの場合の表示は、複数言語対応のページをご覧ください。


「属性」タブ

ページ位置: 要求のプロパティ >

「属性」タブ

要求の属性の値を設定・参照するタブです。「説明」「属性」の2タブ形式の時に表示されます。

ユーザが オプション設定 - ユーザ定義属性 で定義した属性も含まれます

·属性
属性名と属性値が表になっています。変更できない属性の場合は、属性値の背景のみが灰色になります。

WARNING 属性値の変更は、他の属性名や属性値をクリックするまで反映されません。


「関連」タブ

ページ位置: 要求のプロパティ >

「UML要素」タブ

要求に関連するUML要素を設定・参照するタブです。

·関連があるUML要素だけ表示
関連があるUML要素だけ表示します。

·再読み込み
データを再読み込みします。RaQuest起動後 Enterprise Architect でUML要素を増やした場合などに使います。

·ツリー
関連があるUML要素の前のチェックボックスにチェックが入ります。チェックボックスにチェックを入れることで要求とUML要素を関連をつけます。

·コメント
UML要素との関連のコメントを入力します。

·ダイアグラム要素の右クリック
ダイアグラム図を表示します。

WARNING OKボタンを押すまで、変更した関連付けは反映されません。

右クリック

次のメニューが表示されます。

·表示
選択されているUML要素がダイアグラム図だった場合に、そのダイアグラム図を表示します。

·EAで選択
選択されている要素に対応する要素をEAで選択状態にします。この機能を利用するためには、以下が必要です。

oインストール時に「EA要素選択ツール」が選択されてインストールされていること

o該当プロジェクトが同時にEnterprise Architectでも開かれていること

·すべて展開
配下のUML要素をすべて展開します。

·すべて折りたたむ
配下のUML要素をすべて隠します。

オプション（UML要素との関連にステレオタイプを利用）が有効の場合

「UML要素との関連にステレオタイプを利用」オプションが有効の場合、表示項目が増え、以下のようになります。

·関連のステレオタイプ
UML要素との関連のステレオタイプを設定します。


「資料」タブ

ページ位置: 要求のプロパティ >

「資料」タブ

要求に関連するファイルやURLを設定・参照するタブです。

·資料名
資料の名前を記入します。

·資料ID
資料を整理するためのIDを必要に応じて入力します。

·パス
要求に関連する外部の資料です。例えば、WordやExcelなどのファイルや、関連する情報へのURLを入力します。入力された資料を開いて確認することもできます。

·コメント
必要に応じてコメントを入力します。

·「...」(ファイル指定ボタン)
ファイルを指定できます

·表示ボタン
パスに入力されている資料を表示します。ファイルを指定している場合、そのファイルにOSで関連付けられているアプリケーションが立ち上がります。URLの場合はデフォルトブラウザが立ち上がります。

パスがファイルならばファイルのタイムスタンプと資料登録した日時を比較し、資料登録した日付のほうが過去ならば、赤色で表示します。


「担当者」タブ

ページ位置: 要求のプロパティ >

「担当者」タブ

要求の担当者と役割を設定・参照するタブです。

要求の担当者と、その役割を指定します。多くの場合には、その要求を検討したり管理したりする担当者が定義されます。プロジェクトオプションの動作1タブの「部署名を担当者として選択可能」がオン場合、担当として部署名を指定することも可能です。

·担当者
担当者を指定します。担当者ツリーにログインユーザーと同じ名前の担当者が定義されている場合は、ログインユーザーが選択されます。

·役割
指定された担当者の役割を指定します。既定値では「担当者」となっていますが、プルダウン選択や自由に入力することができます。

·開始日
指定された担当者に割り当てられた作業の開始の日付を指定します。

·終了日
指定された担当者に割り当てられた作業の終了の日付を指定します。

·進捗%
指定された担当者に割り当てられた作業の進捗率を指定します。

·予測時間
指定された担当者に割り当てられた予測時間を指定します。

·割当時間
指定された担当者に割り当てられた割当時間を指定します。

·実際の時間
指定された担当者に割り当てられた実際の時間を指定します。

·説明
指定された担当者に割り当てられた作業の説明を入力します。

ここで入力された情報は、Enterprise Architectの対応要素の「担当者の割り当て」サブウィンドウで参照・編集が可能です。

加えて、Enterprise Architectでガントチャート形式として表示が可能です。


「テスト項目」タブ

ページ位置: 要求のプロパティ >

「テスト項目」タブ

要求のテスト項目を設定・参照するタブです。

·名前
テスト項目名を記入します。

·分類
テスト項目の分類を選択します。単体・統合・システム・受け入れ・シナリオから選択します。

·種類
テスト項目の種類を選択します。EAのプロジェクトリボン | リファレンス情報 | 既定値 | 保守 | テストの種類で定義されている項目から選択します。

·状態
テスト項目の状態を選択します。未実施・成功・失敗・保留・中止から選択します。

·最終実施日
テスト項目の最終実施日を入力します。

·実施者
テスト項目の実施者を選択します。

·確認者
テスト項目の確認者を選択します。

·説明・入力・合格基準・結果
テスト項目の説明・入力データ・合格基準・結果を入力します。


「コメント」タブ

ページ位置: 要求のプロパティ >

「コメント」タブ

要求のコメントを設定・参照するタブです。

·日時
記入を行った日時です。変更することはできません。

·発言者
コメントの発言者を記入します。既定値ではログインユーザーが設定されます。

·公開
コメントを公開するかどうかの指定です。公開を指定した場合には、HTMLエクスポート時のコメント一覧に含まれます。Enterprise Architectの保守サブウィンドウの問題点の項目にも格納します。

·コメント内容
要求に関連する変更点や問題点などを議論した結果を保存するために利用します。


「再検討」タブ

ページ位置: 要求のプロパティ >

「再検討」タブ

再検討影響元要求の確認、再検討の確認を行うタブです。

·再検討影響元一覧
この要求が「再検討が必要」となった原因の影響元要求の一覧を示しています。

·影響元要求参照
一覧で選択している影響元要求（再検討が必要となった原因の要求）のプロパティを表示します。

·再検討済
影響元要求の変更内容等を確認し、この要求の再検討が終了した際に、一覧で影響元要求を選択してこのボタンを押してください。これにより再検討影響元一覧から影響元要求が消え、影響元要求の変更の影響による、この要求の再検討が終了したことを示します。

プロジェクトオプションの動作1タブ「再検討影響元一覧が空になったとき、要求の再検討フラグを削除」で、再検討影響元一覧からすべてが消えると自動的に概要タブの再検討フラグを消すように設定が可能です。


「更新履歴」タブ

ページ位置: 要求のプロパティ >

「更新履歴」タブ

ユーザが要求の属性に対して行った変更履歴を参照するタブです。概要・詳細・ユーザ定義属性タブ（または、説明・属性タブ）の内容の履歴だけを取ります。他のタブ（UML要素・資料・担当者・テスト項目・コメント・再検討の各タブ）の内容の変更については履歴は取りません。

·リビジョン
更新履歴のリビジョンを表示します。

·更新日時
更新履歴の更新した日時を表示します。

·更新者
更新履歴の更新者を表示します。

·更新内容
更新履歴の更新内容を表示します。

·表示
選択しているビルドの状態での要求詳細を開きます。

·ロールバック
選択しているビルドの状態に戻します。

·相違点(現ビルドでは未提供機能)
選択しているビルドとの差分を表示します。


「属性(複数編集)」ダイアログ

ページ位置: 要求のプロパティ >

「属性(複数編集)」ダイアログ

複数の要求の属性の値をまとめて設定するタブです。一覧で複数の要求をチェックし、複数要求属性編集(もしくは一覧のコンテキストメニュー 複数処理 -> 属性編集)を選択した時に表示されます。

ユーザが オプション設定 - ユーザ定義属性 で定義した属性も含まれます

·属性
属性名と属性値が表になっています。変更した属性のみが変更されます。変更できない属性の場合は、属性値の背景のみが灰色になります。変更した属性の背景が薄い青色(Light Sky Blue)になります。

WARNING 属性値の変更は、他の属性名や属性値をクリックするまで反映されません。


「説明」(複数言語)タブ

ページ位置: 要求のプロパティ >

「説明」(複数言語)タブ

要求の概要と詳細・概要(言語)と詳細(言語)の設定・参照タブです。複数言語が有効なプロジェクトの場合に表示します。

·概要
要求の概要です。

·(言語選択プルダウン)
概要(言語)・別名(言語)・詳細(言語)欄に表示する言語の選択です。

·概要(言語)
言語選択プルダウンで選択した言語で記載した、要求の概要です。

·別名
要求の別名です。ローカルオプションの表示1タブの「別名を概要・説明タブに表示」により非表示になります。

·別名(言語)
言語選択プルダウンで選択した言語で記載した、要求の別名です。ローカルオプションの表示1タブの「別名を概要・説明タブに表示」により非表示になります。

·詳細
要求の詳細情報を入力します。改行して複数行にわたって入力することができます。入力ボックスの上のボタンやコンテキストメニューを利用して装飾することも可能です。
「フォント設定」ボタンと「表の挿入」ボタンの利用はできません。

·詳細(言語)
言語選択プルダウンで選択した言語で記載した、要求の詳細情報を入力します。改行して複数行にわたって入力することができます。入力ボックスの上のボタンやコンテキストメニューを利用して装飾することも可能です。
「フォント設定」ボタンと「表の挿入」ボタンの利用はできません。


パッケージのプロパティ

ページ位置:

パッケージのプロパティ

パッケージのプロパティは、ルートパッケージとそれ以外のパッケージで異なります。それぞれのプロパティの内容はそれぞれの説明を参照してください。

·ルートパッケージのプロパティ

·パッケージのプロパティ


ルートパッケージのプロパティ

ページ位置: パッケージのプロパティ >

ルートパッケージのプロパティ

ルートパッケージのプロパティには、次のような項目があります。

·名前
ルートパッケージの名前です。

·ID
ルートパッケージに関連するIDです。オプション設定により、パッケージに含まれる要求のIDに、ここで指定されるIDを付加することができます。詳細は「ローカルオプション」->「表示2」をご覧ください。

·IDカウンタ
「プロジェクトオプション」->「状態と初期値」で「パッケージごとに採番」を選択した場合のIDカウンタを指定します。

·表示一覧項目名
パッケージの要求一覧を表示するときに、使用する一覧項目の設定名です。

o「ローカル設定」の場合は、ローカルオプションの一覧項目のユーザ毎の設定を利用します。

o「ローカル設定」以外の場合は、その名前を持ったプロジェクトオプションの一覧項目の設定を利用します。

·システムの目的
管理する要求のシステムの目的です。ドキュメント出力時にドキュメントに含まれます。

·システムの範囲
管理する要求のシステムの範囲です。ドキュメント出力時にドキュメントに含まれます。

·概要
管理する要求のシステムの概要です。ドキュメント出力時にドキュメントに含まれます。


パッケージのプロパティ

ページ位置: パッケージのプロパティ >

パッケージのプロパティ

パッケージのプロパティには、次のような項目があります。

·名前
パッケージの名前です。

·ID
パッケージに関連するIDです。オプション設定により、パッケージに含まれる要求のIDに、ここで指定されるIDを付加することができます。詳細は「ローカルオプション」->「表示2」をご覧ください。

·IDカウンタ
「プロジェクトオプション」->「状態と初期値」で「パッケージごとに採番」を選択した場合の、パッケージのIDカウンタを指定します。

·表示一覧項目名
パッケージの要求一覧を表示するときに、使用する一覧項目の設定名です。

o「ローカル設定」の場合は、ローカルオプションの一覧項目のユーザ毎の設定を利用します。

o「継承」の場合は、親パッケージの設定を利用します。

o「ローカル設定」「継承」以外の場合は、その名前を持ったプロジェクトオプションの一覧項目の設定を利用します。

·要求カテゴリ
パッケージに要求を作成するときの要求カテゴリを指定します。

·概要
パッケージの概要です。ドキュメント出力時にドキュメントに含まれます。


個別機能の詳細

ページ位置:

個別機能の詳細

ここでは、RaQuestで利用可能ないくつかの機能の詳細について説明しています。


SysMLデータプロジェクト

ページ位置: 個別機能の詳細 >

SysMLデータプロジェクト

SysMLデータプロジェクトに設定することで、Enterprise ArchitectのSysMLのデータを扱うことが出来ます。SysMLデータプロジェクトでは、以下のように動作が変化します。

·要求をEAのSysMLの要求として保存

·要求詳細を text タグ付き値に保存

·要求IDを id タグ付き値に保存

·関係

o要求間の関係：ステレオタイプ deriveReqt の依存線

oユースケースとの関係：ステレオタイプ refine の依存線

oテストケースとの関係：ステレオタイプ verify の依存線

oその他要素との関係：ステレオタイプ satisfy の依存線

o親要求との関係：包含線(ネスト)

·親要素がパッケージの場合、パッケージとの関係として包含線（ネスト）を作成

·要求の種類は、SysMLの種類を指定

·関係図をSysML形式で表示

·RaQuestバージョン4.0以前で開けない

·プロジェクトオプション「IDを概要の前に付与して保存」を無効に固定

·プロジェクトオプション「要求の詳細欄で拡張書式を利用」を無効に固定

·プロジェクトオプション「要求を別の要求の下に作成したときに、自動的に関係を作成」を有効に固定

·プロジェクトオプション「作成する関係の種類を指定」を有効に固定・種類を「ネスト」(包含線)に固定


関係図

ページ位置: 個別機能の詳細 >

関係図

·関係図

関係図は、指定した要求と他の要求間の関係を図として表示したものです。図は、Enterprise Architectのダイアグラムとして作成され、表示されます。方向を影響先要求にすることで、指定した要求の変更が影響を与える要求を図として表示できます。また、再検討を色付け表示がオンの時に、再検討が必要な要求は緑色で表示されます。これにより、検討しなければならない要求を簡単に確認することができます。

·SysMLデータプロジェクト（SysML形式で表示）の場合、下図のようにSysML属性を表示します。
146

·作成された関係図に対応するEAのダイアグラムは、プロジェクトオプション - 動作1「関係図を要求の子ダイアグラムとして保存」の設定により、以下のいずれかに作成されます。必要に応じてEnterprise Architect側からダイアグラムの編集などが可能です。

o「RaQuest」という名前のモデルルートパッケージの下のWorkパッケージ

o要求の子ダイアグラム

·関係図では、図の中の要求のダブルクリックで、プロパティダイアログまたは右下に、その要求の詳細を表示します。

·オプション設定 - 表示1の設定により、一覧部分への表示・要求の状態に応じた色付け・レイアウトの変更が可能です。

·コンテキストメニューで一時的にレイアウトなどの変更が可能です。
147


既存のプロジェクトからの要求の生成

ページ位置: 個別機能の詳細 >

既存のプロジェクトからの要求の生成

新規に要求項目を作成するのではなく、既存のEnterprise Architectプロジェクトから要求項目を作成し、それを利用することも可能です。

ユースケースを要求として読み込む場合

ユースケースを要求として読み込む場合には、「ツール」->「Enterprise Architect連携」->「現在のプロジェクトから読み込み」->「ユースケースから要求の生成」を選択します。表示されたダイアログで対象パッケージを指定し実行ボタンを押してください。指定したパッケージ以下の構成と同じ構成で、要求項目が作成されます。また、ノートなど一部の情報については、そのまま要求項目に設定されます。

読み込み後にはプロジェクトの再読み込みが自動的に行われ、読み込んだ要求要素を実際に確認できるようになります。その後、属性値や担当者などを個別に設定してください。

Enterprise Architectの要素に要求が定義されている場合

Enterprise Architectの利用方法によっては、Enterprise Architectのユースケース要素やその他Enterprise Architectの要素のプロパティダイアログ内の「要求」タブに、関連する要求を設定している場合があるかと思います。この場合には、定義されている要求をRaQuestの要求項目として利用することができます。

「ツール」->「Enterprise Architect連携」->「現在のプロジェクトから読み込み」->「要素の内部要求の読み込み」を選択します。要素の内部要求を、要求項目として作成されます。

読み込み後にはプロジェクトの再読み込みが自動的に行われ、読み込んだ要求要素を実際に確認することができるようになるかと思います。パラメータや担当者などを個別に設定してください。

なお、オプションで、「内部要求を読み込むときに外部要求に変更」することができます。

このオプションを利用した場合には、要素のプロパティダイアログで見た場合、下記のように以前とほとんど変わらない表示になり、便利に参照・利用することができます。


一覧の読み込みと出力

ページ位置: 個別機能の詳細 >

一覧の読み込みと出力

CSV/Excel のインポート/エクスポートを選択すると下記のダイアログが表示されます。それぞれの項目を設定し、実行ボタンを押下することで、一覧の読み込みまたは出力が実行されます。

·タブ
読み込みまたは出力する要求の一覧のタブを選択します。

·形式
出力の際の形式を設定します。

·内容
読み込みまたは出力する要求の内容を設定します。表示一覧は一覧に表示している項目をそのままの順番で出力します。設定の場合は、「一覧の入出力形式の設定」で設定した項目名を選択することで、あらかじめ設定した内容で読み込みまたは出力を行います。

·出力日時と出力者をヘッダに出力
出力日時と出力者を一行目に出力します。

·論理値を true/false ではなく * と "" で出力
論理値を true/false ではなく、旧形式の * と "" で出力します。

·コードページ UTF-8 で出力
UTF-8 で出力します。

·処理
読み込みまたは出力のどちらを行うか選択します。

·上書き対象
読み込み時に上書き対象を決定する条件を選択します。

·ファイル
読み込みまたは出力するファイルを選択します。

·状況
読み込みまたは出力の実行状況を表示します。

INFO 先頭に'-'が入ったデータをインポートすることで要求の削除が可能です。関係のIDの前に'-'が入ったデータをインポートすることで関係の削除が可能です。

一覧の入出力形式の設定

読み込みまたは出力の際のファイルの内容の設定を行います。

·設定の名前
設定の名称を入力または選択します。

·分割記号
分割の記号を設定します。CSVファイルの読み込みまたは出力の時のみ有効です。

·既定のファイル名
この設定を選択したときの既定のファイル名を設定します。

·既定の向き
この設定を選択したときの読み込みまたは出力の既定値を設定します。

·既定の上書き対象
この設定を選択したときの上書き対象の既定値を設定します。

·利用可能な項目
読み込みまたは出力可能な項目を表示します。

·ファイルの内容
読み込みまたは出力に使われる項目を表示します。

·上/下
ファイルの内容の項目の順番を変更します。

·項目の追加/削除
ファイルの内容の項目の追加または削除します。

·新規
設定を初期化し新規設定を設定できるようにします。

·保存
設定を保存します。

·別名で保存
設定を別名で保存します。

·削除
設定を削除します。

·キャンセル
設定の変更を終了し、戻ります。

WARNING エクスポート可能な項目でも、インポート不可の項目もあります。


ドキュメントファイルへの出力

ページ位置: 個別機能の詳細 >

ドキュメントファイルへの出力

RaQuestはHTML, RTFファイルへ出力可能です。HTML, RTFへのエクスポートを選択すると下記のダイアログが表示されます。それぞれの項目を設定し、実行ボタンを押下することで、ドキュメントファイルへの出力が実行されます。

·出力形式
出力の形式を設定します。

·テンプレート名
RTFファイル出力時にドキュメントのテンプレートの名前を設定します。

·オプション

oHTMLタグを有効にする
パッケージや要求の詳細に含まれるHTMLタグをタグとして認識します(例:<B>のようなHTMLタグを&lt;B&gt;のように置換しません)。

o章番号を追加
各パッケージに章番号を追加します。

oパッケージのIDを要求のIDに付加
パッケージにIDが指定されているときに、パッケージのIDと要求のIDをあわせたものを要求のIDとして表示します。

·対象パッケージ
出力する対象のパッケージを選択します。

·ファイル
出力するファイルを選択します。

·状況
出力の実行状況を表示します。

RTFファイルへの出力

RTFファイルへの出力はEnterprise Architectのドキュメントの生成機能を利用していますので、Enterprise Architectのドキュメントのテンプレートエディタを利用しカスタマイズが可能です。

RaQuest属性タグ

RaQuestからのRTFファイルへのエクスポートでは、RaQuest の属性を個別に出力可能です。例えば、IDの出力をするときには、下記の形で入力してください。({Element.GUID} の部分は、EAのドキュメントのテンプレートエディタにて右クリックしGUIDを選択して入力してください。)

使用可能なタグは以下の通りです。

概要 | {RQ_概要{Element.GUID}}
詳細 | {RQ_詳細{Element.GUID}}
ID | {RQ_ID{Element.GUID}}
リビジョン | {RQ_リビジョン{Element.GUID}}
バージョン | {RQ_バージョン{Element.GUID}}
フェーズ | {RQ_フェーズ{Element.GUID}}
登録日時 | {RQ_登録日時{Element.GUID}}
更新日時 | {RQ_更新日時{Element.GUID}}
期限 | {RQ_期限{Element.GUID}}
登録者 | {RQ_登録者{Element.GUID}}
最終更新者 | {RQ_最終更新者{Element.GUID}}
承認者 | {RQ_承認者{Element.GUID}}
状態 | {RQ_状態{Element.GUID}}
種類 | {RQ_種類{Element.GUID}}
優先度 | {RQ_優先度{Element.GUID}}
難易度 | {RQ_難易度{Element.GUID}}
安定度 | {RQ_安定度{Element.GUID}}
作業量 | {RQ_作業量{Element.GUID}}
リスク | {RQ_リスク{Element.GUID}}
優先度値 | {RQ_優先度値{Element.GUID}}
キーワード | {RQ_キーワード{Element.GUID}}
ロックフラグ | {RQ_ロックフラグ{Element.GUID}}
承認済みフラグ | {RQ_承認済みフラグ{Element.GUID}}
検討済みフラグ | {RQ_検討済みフラグ{Element.GUID}}
要再検討フラグ | {RQ_要再検討フラグ{Element.GUID}}
影響元ID | {RQ_影響元ID{Element.GUID}}
親要求ID | {RQ_親要求ID{Element.GUID}}
影響先ID | {RQ_影響先ID{Element.GUID}}
所属パッケージ | {RQ_所属パッケージ{Element.GUID}}
ユーザ定義属性 | {RQ_(ユーザ定義属性名){Element.GUID}} 例: {RQ_課題{Element.GUID}}(課題という名前のユーザ定義属性がある場合)

「資料」「コメント」は以下の方法で含めてください。

·「資料」
RaQuest の資料は、Enterprise Architectのファイルに相当しますので、EAのドキュメントのテンプレートエディタの左のツリーの パッケージ-要素-ファイル にチェックを入れ、エディタ上で、ファイルパス・ノートなどを選んでください。ノートを選択した場合、資料コメントの前に資料名・資料ID・最終更新日時を追加された形で出力します。

·「コメント」
RaQuest 上のコメントタブで、公開のチェックボックスにチェックを入れてください。これでRaQuestのコメントが、Enterprise Architectの保守サブウィンドウの問題点の項目になります。ですので、EAのドキュメントのテンプレートエディタの左のツリーの パッケージ-要素-問題 にチェックを入れ、エディタ上で、ノートを選んでください。


ベースライン

ページ位置: 個別機能の詳細 >

ベースライン

ベースライン機能を利用すると、対象のシステムやアプリケーションを開発する際に、指定した状態を保存しておくことができます。具体的には、指定した時の状態を個別に保存しておくことができます。保存しておいたベースライン情報は、必要に応じて呼び出して内容を確認することができます。また、ベースラインと現在の状態の差分を表示させることもできます。

以下の操作が可能です。

·差分の表示
現在の状態との差分を表示します。

·ベースラインに戻す
選択したベースラインに戻します。その際現在の状態を「作業中の情報」として保存します。

·作業中の情報に戻す
前回ベースラインに戻したときに保存した「作業中の情報」に戻します。

·新規ベースライン
新規ベースラインを作成します。

·詳細の変更
ベースラインの名前・バージョン・ノートを変更します。

·ベースラインの削除
選択したベースラインを削除します。

·ファイルの読込
ファイルからベースラインを読み込みます。

·ファイルの出力
ベースラインをファイルへ出力します。

WARNING Enterprise Architectのエディション・プロジェクトの種類により、可能な操作が異なります。

エディション

·Enterprise Architectコーポレート版以上との組み合わせ：すべて可能

·デスクトップ版・プロフェッショナル版との組み合わせ：「ベースラインに戻す」「作業中の情報に戻す」「新規ベースライン」が可能

プロジェクトの種類

·FEAPファイル/サーバリポジトリ/暗号化接続文字列：「ファイルの読込」「ファイルの出力」は不可

ベースラインの分岐

プロジェクトによっては、途中でベースラインを分岐する場合があるかもしれません。この場合には、まず、「新規ベースラインを作成」します。その後、作成した「ベースラインに戻す」で分岐の元になるベースラインを読み込みます。この状態で「新規ベースラインの作成」を選択すると、既存のベースラインファイルを基にして新しいベースラインを展開することができるようになります。


変更要求の作成と管理

ページ位置: 個別機能の詳細 >

変更要求の作成と管理

要求を定義した後その要求に変更があった場合には、変更要求を定義して、その変更要求を管理することになります。ここでは、この変更要求の作成方法と管理の方法について説明します。

なお、この変更要求は、対象となる要求が定義された後、承認されてベースラインが変更になった後に利用することを想定しています。ベースラインの変更前の場合には、対象の要求を直接修正することを想定してます。また、同様の理由で、変更要求には変更要求を追加することはできません。

変更要求の作成

変更要求を作成するには、「承認済み」の既存の要求を対象として選択する必要があります。その上で、メインメニュー ->「要求」->「新規変更要求」を選択します。変更要求のプロパティダイアログが表示されますので、必要な情報を入力します。

変更要求が作成されると、対象の既存の要求は完全に編集不可になります。これ以降、すべての操作は変更要求に対して行います。

変更要求からは、プロパティダイアログの「変更元要求」ボタンを押すことで、変更元になっている要求の内容を簡単に確認することができます。

変更要求作成の影響

変更要求の作成直後、および変更要求を「検討済み」以降の状態にあるときに再修正した場合、変更元要求に関係するすべての要求項目は自動的に「要再検討」状態となります。つまり、変更元要求を編集した場合と同等の扱いになります。変更要求を作成後、関係するすべての要求を変更要求の内容にあわせて再度検討する必要性があるからです。

変更要求の管理

変更要求は、作成後は通常の要求と同じ扱いになります。「検討終了」し、「承認」する必要があります。


「再検討が必要」な要求

ページ位置: 個別機能の詳細 >

「再検討が必要」な要求

関連する要求項目を変更すると、「再検討が必要」という状態に自動的に設定される場合があります。これは、その要求が依存する(その要求に影響する)他の要求が変更された場合に発生します。このような場合には、他の要求の変更内容を確認して、再検討を行う必要があります。

「再検討が必要」の状態になった原因の要求を確認する

要求が「再検討が必要」の状態になった場合には、原因となった要求の変更内容を確認する必要があります。要求のプロパティダイアログには「再検討」タブがあります。このタブで表示される「再検討影響元一覧」に表示される要求が、変更された要求になります。

これらの要求の内容を確認して、必要に応じて要求の内容を修正します。検討が完了したら、一覧から要求を選択して「再検討済｣ボタンを押します。これにより、変更による影響範囲確認の作業が完了したことを意味します。

「再検討が必要」の状態を解除する

「再検討が必要」の状態を解除するには、プロパティダイアログの最初のタブ「概要」にある「再検討が必要」のチェックボックスのチェックを外します。


用語集

ページ位置: 個別機能の詳細 >

用語集

RaQuestでは、要求管理中に利用される用語を管理することもできます。この用語集機能は、付属のEnterprise Architectの用語集アドイン機能と完全互換ですので、登録した内容はEnterprise Architectからもアドインの用語集より確認することができます。

用語集の利用

用語集のダイアログは、メインメニュー ->「プロジェクト」->「用語集」を選択すると表示されます。用語集で定義できる内容や操作方法はEnterprise Architectの用語集アドインと同様です。

定義した用語集の利用

この用語集で定義した内容は、次の方法で活用することができます。

概要設計においてクラスとして利用

「用語集からクラスを生成」機能を利用することで、用語集で定義された単語と同名のクラスを簡単に作成することができます。メインメニュー ->「ツール」->「Enterprise Architect連携」->「用語集からクラスを生成」を選択すると、生成位置を指定するためのダイアログが表示されます。ここで選択した位置にクラスが生成されます。反映する項目は「名前」「英語表記」「説明」です。

Enterprise Architectからの参照

ここで定義した用語はEnterprise Architectからも同じ形式で参照が可能です。詳細はEnterprise Architectの用語集アドイン機能を参照ください。

用語集の出力

用語集の出力には、Enterprise Architect上で、RaQuest用語集アドインの機能をご利用ください。


担当者

ページ位置: 個別機能の詳細 >

担当者

RaQuestの担当者ツリーで作成した担当者は、Enterprise Architectにおいても担当者として保存されます。

Enterprise Architect での参照方法は、Enterprise ArchitectでRaQuestの情報の参照方法のページをご確認ください。

部署

部署は担当者が所属する部署がEnterprise Architectの個々の担当者の所属に保存されます。部署のツリー構造はRaQuest独自の情報として保存されます。

要求への担当者の割り当て

要求への担当者の割り当ても、Enterprise Architect の担当者割り当てとして保存されます。EAでの参照はEnterprise ArchitectでRaQuestの情報の参照方法のページをご確認ください。この情報は、Enterprise Architectでの進捗管理に使用できます。Enterprise Architect での進捗管理については、Enterprise Architect のヘルプを参照ください。


状態のカウント

ページ位置: 個別機能の詳細 >

状態のカウント

現在定義されている要求項目について、さまざまな項目による要求項目の個数を表示します。この項目の個数を見ることで、全体の状態がどのようになっているのかを把握することが可能です。カウント項目は以下になります。

·要求数

·当日更新要求数

·再検討要求数

·期限超過要求数

·担当割り当て済み要求数

·ロックしている要求数

·検討済み要求数

·承認済み要求数

·関連数(要求間)

·関連数(UML要素)

·資料数

·担当割り当て数

·テスト項目数

·コメント数

·種類別

·状態別

また、保存されている過去の一覧のカウント数のCSV出力が可能です。

保存されるタイミングは、メインメニュー ->「プロジェクト」->「状態のカウント」->「現在の状態数の表示」を行ったときです。オプションの動作1の「終了時に自動的に状態数を保存」にチェックが入っている場合は終了時に状態数の保存が行われます。保存されているものは一日に対し一つであり、カウントを行うと上書き保存されます。


ワードアドイン

ページ位置: 個別機能の詳細 >

ワードアドイン

インストール時に「ワードアドイン」を選択している場合、Microsoft Word で文字を反転させ、右クリックして表示されるメニューに"RaQuestへ登録"というメニューが追加されています。Microsoft Word と RaQuest を同時に起動している場合、このメニューを選択することによって、RaQuest で開いているプロジェクトに選択した文字が要求として登録できます。

選択した文字が一行の場合、選択した文字が要求の概要になります。選択した文字が複数行の場合、選択した文字の一行目が要求の概要になり、それ以降の行が要求の詳細になります。要求の概要と詳細以外の項目は既定値が入ります。

登録が完了した場合、以下のダイアログが表示されます。

この機能を使うことで、既存のWordの要求を簡単に取り込むことができます。

WARNING RaQuest にてプロジェクトの再読み込みを行わないと、登録された要求の属性値が不定の場合があります。ご注意ください。


要求移動アドイン

ページ位置: 個別機能の詳細 >

要求移動アドイン

インストール時に「RaQuest要求移動アドイン」を選択している場合、RaQuestで指定した要求パッケージ配下以外のパッケージにEnterprise Architect上で要求を新規作成した場合、作成された要求をRaQuestで指定した要求パッケージ配下に移動します。

この動作は、RaQuestで指定した要求パッケージ配下以外のパッケージで、ダイアグラムを作成し、そのダイアグラムに要求を新規作成した時に、その要求をRaQuestの管理対象にするときに便利です。

WARNING 要求の新規作成時だけで、それ以外のEnterprise Architect上での移動などの時は何も行いません。

WARNING 動作後のメッセージ等はありません。


排他ロック

ページ位置: 個別機能の詳細 >

排他ロック

下記のような、要求属性を変更できる状態にする際に、別のユーザが同時に同じ要求の属性を編集出来ないように、要求毎に排他ロックを自動的に行います。

·要求詳細ダイアログを開いたとき

·一覧で要求属性を編集状態にしたとき

·オプション「要求を常に表示」がオンの場合に、要求属性を編集しようとしたとき

この排他ロックは、Enterprise Architect がプロフェッショナル版以上の時に行われます。排他ロックが行われている要求を別ユーザが開くと、ロック以外の属性が編集できない状態になります。

さらにEnterprise Architect の「セキュリティが有効」であるプロジェクトの場合は、ロックを含めた全ての属性が、別のユーザで編集不可能になる排他ロックが行われます。

加えて、Enterprise Architect の「セキュリティが有効」かつ「編集時には排他ロックが必須」モードのプロジェクトの場合は、RaQuest上で排他ロックの確認・適用・解除を手動で行えます。排他ロックの確認のためにプロジェクトツリーに赤もしくは青の「！」マークを表示します。排他ロックの適用と解除はプロジェクトツリーのコンテキストメニューから行えます。この設定の場合、事前に特定範囲に対して排他ロックを行い編集という作業が簡単に行えます。

148 排他ロックの適用と解除コンテキストメニュー

149 排他ロックの適用と解除ダイアログ


ショートカットキー

ページ位置: 個別機能の詳細 >

ショートカットキー

以下が利用できるショートカットキーです。

CTRL + O | 開く
CTRL + C | コピー
CTRL + X | 切り取り
CTRL + V | 貼り付け
CTRL + F | 詳細検索
F3 | 前方検索
SHIFT + F3 | 後方検索
CTRL + L | 一覧フィルタ
CTRL + H | 置換
CTRL + T | ツリーから検索
CTRL + G | 用語集
CTRL + R | 要求一覧
CTRL + D | TODO一覧
CTRL + P | 新規パッケージ
CTRL + N | 新規要求
CTRL + M | 要求の関係を図示
CTRL + W | タブを閉じる
CTRL + TAB | 次のタブへ（要求詳細のみ）
CTRL + SHIFT + TAB | 前のタブへ（要求詳細のみ）
CTRL + UP | ツリーの上へ移動
CTRL + DOWN | ツリーの下へ移動
CTRL + U | 更新


外部コマンド・外部プログラムとのインタフェース

ページ位置: 個別機能の詳細 >

外部コマンド・外部プログラムとのインタフェース

外部コマンドの呼び出し

設定ファイルを配置することで、RaQuest のメインメニュー ->「ツール」のところに、外部ツール呼び出しメニューを設定可能。

設定

インストールフォルダの下にフォルダを作り（名前は何でも良い）その下に、拡張子 ini のファイルを作る。iniファイルの内部のフォーマットは以下。

MENUNAME=メニュー名
EXECFILE=コマンドフルパス
ARGUMENT=コマンド引数
EXECDIR=コマンド実行時ディレクトリ
SHORTCUT=表示順（ショートカットキー）
DESKTOP=Enterprise Architectデスクトップ版と組み合わせのときの動作
SHOWWINDOW=動作時のWindow状態

·ARGUMENT は引数

o$f プロジェクトのファイルパスまたは接続文字列

o$k 選択している要素の種類

o$g 選択している要素のGUID

o$e 選択している要素のEAID

o$p プロジェクトのGUID

o$%id% など選択している要素が要求のときの属性値
（$%(ユーザ定義属性名)% など）
引数の数を合わせるために、"(ダブルクオート)で囲む必要がありましたら、囲む。

·EXECDIR は省略可（省略した場合は、ini ファイルがあるフォルダ)

·SHORTCUT は 1から10 まで。省略可能
ショートカットキーは CTRL+F1 から CTRL+F10 で対応。

·DESKTOP は省略可 CLOSE/NG/OK が選択肢
CLOSE は、Enterprise Architectデスクトップ版だと一旦クローズ(デフォルト)
NG は Enterprise Architectデスクトップ版だと実行不可
OK は Enterprise Architectデスクトップ版でも実行

·SHOWWINDOW は省略可（省略した場合は、通常表示）
0 は非表示
1 は通常表示

例：
MENUNAME=メニュー名
EXECFILE=C:\test.bat
ARGUMENT="$f" $g
EXECDIR=C:\
SHORTCUT=1
DESKTOP=CLOSE
SHOWWINDOW=1

上記の場合：

·メニューには「メニュー名」で表示

·実行ファイルは C:\test.bat

·引数は、現在開いているプロジェクトファイル($f)と現在選択している要素のGUID($g)

·実行時ディレクトリは、C:\

·ショートカットキーは CTRL+F1

·EAデスクトップ版との組み合わせは、プロジェクトを一旦閉じて、実行終了後、開きなおす。

·画面は通常表示

外部プログラムからの要求の選択/更新

ライブラリ(インストールディレクトリの RaQuestMessageLib.dll) を利用する

ライブラリの関数

·SetTargetProjectGUID:メッセージ送信対象プロジェクトを指定

·FindTargetInstance:指定した対象プロジェクトを開いているRaQuestを検索

·UpdateRequirement:要求の更新メッセージ送信

·SelectRequirement:要求の選択メッセージ送信

·CloseMessage:メッセージ送信終了

サンプルプログラム

以下webページを参照してください。

外部コマンド・外部プログラムとのインタフェースについて


計算機能

ページ位置: 個別機能の詳細 >

計算機能

優先度値と計算式型のユーザ定義属性には、計算式を設定し計算結果の数値を表示させることが可能です。優先度値の計算式はプロジェクトオプションの動作2タブに定義してください。計算式型のユーザ定義属性計算式はプロジェクトオプションのユーザ定義属性タブに定義してください。

計算式には、変数・数値・演算子(+,-,*,/)・括弧() が利用可能です。$で始まる変数には、以下が指定可能です。

·$優先度

·$難易度

·$リスク

·$安定度

·$作業量

·$(ユーザ定義属性)

$優先度・$難易度・$リスク・$安定度には高=3、普通=2、低=1が割り当てられています。$(ユーザ定義属性) は、数値型・列挙型・計算式型が指定可能です。列挙型の場合は、該当文字列に数値が入っている必要があります。

計算順

計算式型のユーザ定義属性を定義順に上から計算し、最後に優先度値を計算する順番となっています。計算の時点で値がない変数は0として計算を行います。

内部データ型

32bit int (-2,147,483,648 〜 2,147,483,647)


複数言語対応

ページ位置: 個別機能の詳細 >

複数言語対応

プロジェクトファイルに対し、Enterprise Architectのプロジェクトのオプションの「複数言語の設定」を有効にし利用言語を設定することで、Enterprise Architectの翻訳タブのデータをRaQuestで表示・編集することが出来ます。

複数言語が有効のプロジェクトファイルでは、以下のように動作が変化します。

·要求のプロパティの「説明」タブの部分に「説明」(複数言語)タブを表示するように変更

·プロジェクトオプション「このプロジェクトでは、属性を一覧形式で表示」を有効に固定

·プロジェクトオプション「要求の詳細欄で拡張書式を利用」を無効に固定


オプション設定

ページ位置:

オプション設定

RaQuestでは、いくつかの機能の動作をカスタマイズすることができます。このオプション設定は、プロジェクトファイルに保存され、プロジェクトファイルを利用する利用者すべてに影響する項目（プロジェクトオプション）と、レジストリに保存され、利用者ごとに設定可能な項目（ローカルオプション）があります。

·プロジェクトオプション

o要求の種類

o要求の状態

o状態と初期値

o要求カテゴリ

o動作

oユーザ定義属性

o一覧項目

oパッケージ

·ローカルオプション

o表示

oフォント

o一覧項目

o色

ローカルオプションはプロジェクトファイルを読み込まなくても設定が可能です。

オプションダイアログはいくつかのタブで構成されています。以下、タブごとに設定内容の詳細を説明します。


プロジェクトオプション

ページ位置: オプション設定 >

プロジェクトオプション

プロジェクトオプションは、プロジェクトファイルに保存され、プロジェクトファイルを利用する利用者すべてに影響するオプションです。要求の種類や状態・ユーザ定義属性・動作などの設定です。プロジェクトファイルを開かないと設定できません。

·プロジェクトオプション

o要求の種類

o要求の状態

o状態と初期値

o要求カテゴリ

o動作

oユーザ定義属性

o一覧項目

oパッケージ

以下、タブごとに設定内容の詳細を説明します。


プロジェクトオプション - 要求の種類

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 要求の種類

このページでは、要求の種類を設定することができます。

·種類
種類の名前を指定します。

·説明
種類の説明を指定します。

·ノート
種類のノートを指定します。

·上・下ボタン
種類の順番を変更します

·新規・保存・削除ボタン
種類の新規作成・保存・削除を行います。

·「EAの追加の要求要素」の種類を追加ボタン
EAの要求図のツールボックスの「追加の要求要素」にある要素に対応する要求の種類の追加を行います。

WARNING 状態と初期値タブや要求で利用されている種類は削除できません。


プロジェクトオプション - 要求の状態

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 要求の状態

このページでは、要求の状態を設定することができます。

·状態
状態の名前を指定します。

·説明
状態の説明を指定します。

·色
状態の色を指定します。（オプション「プロジェクト毎の設定色を使う」がオンの時に使われます。文字色として利用される場合に、薄すぎる色は、少々濃くなるように自動的に変更される場合があります。）

·上・下ボタン
状態の順番を変更します

·新規・保存・削除ボタン
状態の新規作成・保存・削除を行います。

WARNING 状態と初期値タブや要求で利用されている状態は削除できません。


プロジェクトオプション - 状態と初期値

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 状態と初期値

具体的な設定項目とその意味は次の通りです。

·状態の既定値
新規に要求を作成するときの状態の既定値を指定します。

·検討済みを示す状態
RaQuestが、要求を「検討済み」であると認識する状態名を指定します。

·承認済みを示す状態
RaQuestが、要求を「承認済み」であると認識する状態名を指定します。

·種類の既定値
新規に要求を作成するときの種類の既定値を指定します。

·バージョンの既定値
作成する要求項目のバージョンの既定値を入力します。

·フェーズの既定値
作成する要求項目のフェーズの既定値を入力します。

·自動でID番号付加
要求を作成したときに、自動的にIDを採番します。数値は自動的に１ずつ増えていきます。

o全体で採番
全部の要求に対し、通し番号で採番します。
横の入力欄には桁数分の数値を指定します。

o要求カテゴリごとに採番
要求のカテゴリごとに通し番号で採番します。
値と桁数は、要求カテゴリタブのそれぞれのカテゴリのIDカウンタの設定を使用します。

oパッケージごとに採番
パッケージごとに通し番号で採番します。
値と桁数は、親パッケージのIDカウンタの設定を使用します。

o階層構造で採番
階層構造の形式で採番します。
通し番号とセパレータ・枝番号を指定します。セパレータ・枝番号はフォーマットの指定です。親の要求がない場合は、通し番号のみを採番します。親の要求がある場合は、親の要求のIDに、指定されたセパレータ・枝番号のフォーマットで枝番号を追加したものを採番します。

採番方法の変更などを行った際、下記ダイアログが表示される場合があります。既存の要求に対する処理を選択してください。


プロジェクトオプション - 要求カテゴリ

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 要求カテゴリ

このページでは、要求カテゴリを設定することができます。

·要求カテゴリ
要求カテゴリの名前を指定します。

·EA要素種類
要求カテゴリをEAで参照するときのEAの要素の種類を指定します。

·アイコン
要求カテゴリのアイコンを指定します。

·説明
要求カテゴリの説明を指定します。

·プレフィックス
要求カテゴリのプレフィックスを指定します。

·IDカウンタ
「プロジェクトオプション」 -> 「状態と初期値」で「要求カテゴリごとに採番」を選択した場合のIDカウンタを指定します。

·上・下ボタン
要求カテゴリの順番を変更します

·新規・保存・削除ボタン
要求カテゴリの新規作成・保存・削除を行います。

WARNING 要求カテゴリの設定可能な数に制限はありませんが、新規要求作成のメニューには15個までしか表示されません。


プロジェクトオプション - 動作1

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 動作1

具体的な設定項目とその意味は次の通りです。

·SysMLデータプロジェクト
SysMLデータプロジェクトとして要求を扱うことを指定します。

·閉じる時に自動的に状態数を保存
プロジェクト全体の統計情報を保存し分析できるようにするために、プロジェクトを閉じる時の状態を内部に保存します。

·削除可能
要素の削除ができるようにします。

·要求の削除可能
要求の削除ができるようにします。このチェックがオンでない場合、要求や空でないパッケージは削除できず、要求間の関係や空のパッケージ・担当者・部署などのみが削除できます。

·削除時に確認
要求やパッケージ・担当者・要求間の関係を削除するときに確認のダイアログが表示されます。

·削除時にごみ箱パッケージに移動
要求やパッケージを削除した場合に、すぐに削除せずにごみ箱パッケージに移動します。

·ごみ箱パッケージの表示
ツリーにごみ箱パッケージを表示します。

·要求を別の要求の下に作成したときに、自動的に関係を作成
子要求を新規作成した場合に、自動的に親要求との関係を作成します。この関係は、親要求が変更されたときに子要求に影響する関係です。

·作成する関係の種類を指定
子要求を新規作成した場合に、自動的に親要求との関係を作成する場合に、作成する関係の種類を指定します。依存（デフォルト）・集約・ネストから選択可能です。

·移動時も自動的に関係を作成
新規作成の場合ではなく、ツリー内で要求を移動し、他の要求の子要求にした場合に、自動的に関係を追加します。

·移動時は削除も実行
他の要求の子要求になっている要求をツリー内で要求を移動した場合に、作成されている親要求との関係を自動的に削除します。

·移動先パッケージの指定要求カテゴリに変更
移動先のパッケージに要求カテゴリが指定されていた場合、移動した要求の要求カテゴリを移動先の指定要求カテゴリに変更します。

·部署名を担当者として選択可能
担当者を設定するコンボボックスに部署名も項目として表示します。

·再検討影響元一覧が空になったとき、要求の再検討フラグを削除
再検討影響元一覧に表示する再検討影響元要求がなくなったときに、自動的にその要求の再検討フラグを消去します。

·このプロジェクトでは、属性を一覧形式で表示
ローカルオプションの表示1タブの「属性を一覧形式で表示」の状態に関わらず、このプロジェクトでは、「説明」「属性」の2タブ形式で表示するようにします。

·IDを概要の前に付与して保存
関係図やEnterprise Architectで見たときにIDがわかるように、概要の前にIDを付けた文字列を、EAの要素の名前として保存します。

·セパレータ(現ビルドでは未提供機能)
「IDを概要の前に付与して保存」する場合に利用するセパレータを指定します。

·自動IDのプレフィックスの代わりにパッケージIDを付与
「IDを概要の前に付与して保存」する場合に、自動IDのプレフィックスの代わりに所属パッケージIDを付与し、EAの要素の名前として保存します。

·要求IDをソート時に数値として扱う
要求IDを一覧やツリーでソートするときに、文字列ではなく数値として扱うようにします。

·UML要素との関連にステレオタイプを利用
要求詳細のUML要素タブでUML要素との関連付けを行ったときに、作成した関連にステレオタイプを付けられるようにします。

·関係図を要求の子ダイアグラムとして保存
関係図の出力位置を要求の子ダイアグラムにします。EAでドキュメントのテンプレートの編集を行うことで、RTF形式でのドキュメント出力時に要求の関係図を要求と結びつけて出力することが可能になります。

·要求の詳細欄で拡張書式を利用
要求の詳細欄で、フォント設定や表の挿入などの拡張書式を利用することができるようにします。
ご注意: 詳細欄の内容のEAの要素への保存場所が変わります。


プロジェクトオプション - 動作2

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 動作2

具体的な設定項目とその意味は次の通りです。

·優先度値計算式
優先度値を計算する計算式を入力します。計算機能については計算機能を参照してください。

·変更時のコマンド実行
要求の追加・更新・削除時に実行するコマンドとそのパラメータを指定します。指定する実行コマンドによりさまざまな処理が可能です。

o実行コマンド
実行する外部コマンドを指定してください。

oパラメータ
実行する外部コマンドのパラメータを指定してください。$datafile$ をテンプレートを元に作成したファイル名に置き換えます。

oテンプレート
変更内容をファイルに出力するテンプレートです。

o実行
コマンドを実行する種別を指定してください。

テンプレートとパラメータに利用可能な変数

テンプレートとパラメータに利用可能な変数は以下の通りです。

·$変更内容$

·$変更種別$
（追加・更新・削除）

·$変更対象$
（要求・コメント・資料・担当者）

·$ID$

·$概要$

·$優先度$

·$状態$

·$作業量$

·$登録日時$

·$更新日時$

·$期限$

·$詳細$

·$バージョン$

·$種類$

·$ロックフラグ$

·$承認済みフラグ$

·$最終更新者$

·$難易度$

·$安定度$

·$リスク$

·$優先度値$

·$登録者$

·$影響元ID$

·$親要求ID$

·$検討済みフラグ$

·$要再検討フラグ$

·$承認者$

·$影響先ID$

·$リビジョン$

·$フェーズ$

·$所属パッケージ$

·$キーワード$

「変更時のコマンド実行」設定例（要求変更時のメール送信設定）

「変更時のコマンド実行」の設定例を示します。下記のように設定することで、要求の追加・更新・削除時にメール送信を可能にすることができます。(日本語版Blat BlatJ は http://www.piedey.co.jp/softs/blat.html からダウンロード可能)

実行コマンド | \\サーバ\共有\ツール\blatj.exe
パラメータ | "$datafile$" -t "受信メールアドレス" -server メールサーバ -f "送信メールアドレス" -s "サブジェクト" $datafile$/受信メールアドレス/送信メールアドレス/サブジェクトは必ず""で囲ってください。
テンプレート | $変更対象$$変更種別$ 更新者: $最終更新者$ ID: $ID$ 概要: $概要$ 詳細: $詳細$ 変更内容: $変更内容$
実行 | チェックを入れる


プロジェクトオプション - ユーザ定義属性

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - ユーザ定義属性

このページでは、要求のユーザ定義属性を設定することができます。

·属性名
属性名を指定します。

·型
属性の型を指定します。

·(値欄)
列挙型の選択肢もしくは計算式型の計算式を指定します。

·上・下ボタン
ユーザ定義属性の順番を変更します。

·新規・保存・削除ボタン
ユーザ定義属性を新規作成・保存・削除します。

計算式型については計算機能を参照してください。

WARNING 属性の型はソート時と入力時のチェックに使用されます。


プロジェクトオプション - 一覧項目

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - 一覧項目

このタブでは、画面右側の一覧表示領域に表示される情報を設定することができます。このタブの設定だけでは一覧には反映されません。一覧項目の名前を、パッケージのプロパティの表示一覧項目名に設定して一覧表示、もしくは、要求一覧の表示一覧項目名で選択を行う必要があります。

このタブの設定は、プロジェクトに保存され、他のユーザでも同じように表示されます。しかし、他のプロジェクトには影響を与えません。

·対象
（指定できません。）

·名前
要求一覧の時の設定対象を指定します。名前はパッケージのプロパティや一覧での指定に利用します。

·新規ボタン
要求一覧の時の設定対象を新規追加します。

·削除ボタン
要求一覧の時の設定対象を削除します。

·非表示項目
選択可能な非表示項目の一覧です。

·表示項目
表示一覧項目です。[⇒]ボタン・[⇐]ボタンを利用して表示内容を指定します。チェックボックスをオンにする事で、一覧で直接編集が可能になります。

·⇑(上)・⇓(下)ボタン
表示される項目の順序を変更します。


プロジェクトオプション - パッケージ

ページ位置: オプション設定 > プロジェクトオプション >

プロジェクトオプション - パッケージ

このページでは、RaQuestで利用するパッケージの指定をすることができます。

·要求パッケージ
指定している要求パッケージを階層構造で表示します。

·ユースケースパッケージ
指定しているユースケースパッケージを階層構造で表示します。

·...ボタン
それぞれのパッケージを指定します。

INFO それぞれのパッケージの意味はパッケージの指定のページに記述してあります。


ローカルオプション

ページ位置: オプション設定 >

ローカルオプション

ローカルオプションは、レジストリに保存され、利用者ごとに設定可能です。フォントや色など主に表示に関するオプションです。プロジェクトファイルを読み込まなくても設定が可能です。

·ローカルオプション

o表示

oフォント

o一覧項目

o色

以下、タブごとに設定内容の詳細を説明します。


ローカルオプション - 表示1

ページ位置: オプション設定 > ローカルオプション >

ローカルオプション - 表示1

具体的な設定項目とその意味は次の通りです。

·カレントユーザ名
プロジェクトを開いているときに、現在利用されるユーザ名を表示します。

·既定のユーザ名
既定のユーザ名を入力します。この設定は再起動するまで反映されません。

·複数起動可能
RaQuest 自体の複数起動を可能にします。

·要求を常に表示
右下に要求を常に表示するようにします。このオプションは再起動するまで反映されません。

o排他ロックのタイミングを要求を選択した時に変更
要求属性を編集しようとしたときではなく、要求を選択した時に排他ロックするようにします。

·プロジェクトを開くときに、全要求一覧を開く
プロジェクトを開くときに、全要求一覧を開きます。

·複数行入力欄で、右端で折り返す
詳細などの複数行入力欄で、右スクロールをせず、右端で折り返すようにします。

·要求属性

o属性を一覧形式で表示
要求のプロパティを「説明」「属性」の2タブ形式で表示するようにします。

§属性の一覧形式表示順を一覧に合わせる
「属性」タブの属性表示順を、現在表示している一覧の表示順にあわせて表示するようにします。

§影響元ID・影響先ID・関連UML要素数などを属性タブに表示
影響元ID・影響先ID・関連UML要素数などの属性を属性タブに表示するようにします。

o別名を概要・説明タブに表示
別名を概要・説明タブに表示するようにします。

·関係図

o関係図を一覧表示領域に表示
関係図を右上の一覧表示の場所に表示します。

o関係図にパッケージ名を表示
関係図の中の要求のパッケージ名を表示します。

o関係図にUML要素を表示
関係図の中にUML要素を表示します。

o関係図にごみ箱パッケージ内の要求を表示
関係図の中にごみ箱パッケージ内の要求を表示します。

o関係図で要求を状態に応じて色付け
関係図の中の要求を、要求の状態に応じて色付けします。要求要素以外については、要素の影の部分の色が変わります。影のない要素やEAのバージョンにより、状態が変わっても見た目は変わらない場合があります。

o関係図で再検討要求を色付け
関係図の中の再検討要求を色付けします。

o方向
指定した要求に加えて関係図に表示する要求の、影響の方向（影響先要求・影響元要求・両方向）を指定します。

oレイアウト
関係図の要求のレイアウトを指定します。


ローカルオプション - 表示2

ページ位置: オプション設定 > ローカルオプション >

ローカルオプション - 表示2

具体的な設定項目とその意味は次の通りです。

·共通

o要求カテゴリのプレフィックスを要求のIDに付加
要求カテゴリにプレフィックスが指定されているときに、要求のID欄に要求プレフィックスを追加したものを表示します。例えば、要求カテゴリのプレフィックスが「R」で、要求のIDが「001」の場合に、「001」とそのまま表示するか、「R001」と表示するかを指定することができます。

oパッケージのIDを要求のIDに付加
パッケージにIDが指定されているときに、パッケージのIDと要求のIDをあわせたものを要求のID欄に表示します。

oツリーと一覧で同じ要求を選択
左側ツリーと右側一覧で選択状態になる要求を同じ要求になるようにします。

·ツリー

oIDをツリーに表示
要求やパッケージのIDをツリーに表示します。

oツリーの中をIDでソート
ツリー内の表示順序において、常にIDでソートします。

oダブルクリックで配下項目の展開
ツリー内の項目をダブルクリックしたときに、項目のプロパティ画面を開くのではなく、配下項目の展開を行います。

oプロジェクトツリーを開くときに、ルートパッケージだけを展開
プロジェクトツリーを開くときに、要求のないパッケージを開くのではなく、ルートパッケージだけの展開を行います。

·一覧

o複数選択のためのチェックボックスを表示
複数選択のためのチェックボックスを表示します。

o単一行を縦方向にセンタリング
単一行を縦方向にセンタリングして表示します。

o文章型の属性を自動改行して表示
文章型の属性を自動改行して表示します。

o一覧表示のカラム幅を自動サイズ調整
右側一覧表示領域のカラムをウインドウ幅に応じて自動的に調整します。

oダブルクリックで直接編集
シングルクリックではなく、ダブルクリックで直接編集するようにします。

o変更要求を持つ要求は一覧に表示しない
右側一覧表示に表示する要求のうち、変更要求を持つ要求を表示しないようにします。

o一覧のタブ名称に「の要求」を追加しない
右側一覧表示のタブ名称に「の要求」を追加しないようにします。

·資料・担当者・テスト項目・コメントタブ

o別の要求を選択したときに、テキストをクリアしない
別の要求の選択に変更したときに、要求詳細の資料・担当者・テスト項目・コメントタブのコメントなどのテキストを消去しないようにします。

o別のタブに変更のときに、保存忘れをチェック
別のタブに変更したときに、そのタブで変更した内容の保存忘れがないかチェックし、保存忘れと推測した場合は確認ダイアログを表示するようにします。


ローカルオプション - 外観・フォント

ページ位置: オプション設定 > ローカルオプション >

ローカルオプション - 外観・フォント

具体的な設定項目とその意味は次の通りです。

·スタイル
Window スタイルを指定します。

·フォント
ツリー・一覧・マトリックス・印刷・要求の詳細・詳細（要求詳細ダイアログの各タブのコメント欄等）のそれぞれで使用するフォントを指定します。


ローカルオプション - 一覧項目

ページ位置: オプション設定 > ローカルオプション >

ローカルオプション - 一覧項目

このタブでは、画面右側の一覧表示領域に表示される情報を設定することができます。パッケージのプロパティの表示一覧項目名や要求一覧の表示一覧項目名が「ローカル設定」のときに使われる設定です。

このタブの設定は、ローカルレジストリに保存され、他のプロジェクトでも利用されます。しかし、他のユーザには影響を与えません。

·対象
対象の一覧を指定します。

·名前
（指定できません。）

·新規ボタン
（利用できません。）

·削除ボタン
（利用できません。）

·非表示項目
選択可能な非表示項目の一覧です。

·表示項目
表示一覧項目です。[⇒]ボタン・[⇐]ボタンを利用して表示内容を指定します。チェックボックスをオンにする事で、一覧で直接編集が可能になります。

·⇑(上)・⇓(下)ボタン
表示される項目の順序を変更します。


ローカルオプション - 色

ページ位置: オプション設定 > ローカルオプション >

ローカルオプション - 色

表示色を変更します。対象の状態のボタンを押すと、色を選択することができます。

·一覧要素の状態による色
一覧内の特定の状態の要求の表示色を変更します。

oプロジェクト毎の設定色を使う
プロジェクト毎に設定される状態の色を使用するようにします。このチェックを入れた場合、独自色は設定できません。

o検討済み
検討済み要求の色

o承認済み
承認済み要求の色

o期限超過
期限超過の要求の色

o再検討が必要
再検討が必要な要求の色

o前回以降更新
前回以降更新の要求の色
（一回前に該当プロジェクトファイルを開いた時刻以降に他ユーザが更新した要求の色）

o今回更新
前回以降更新の要求の色
（今回プロジェクトファイルを開き、更新した要求の色）

·ツリーと一覧の選択項目

o文字色
フォーカスがない場合のツリーと一覧の選択部分の文字色

o背景色
フォーカスがない場合のツリーと一覧の選択部分の背景色

·変更中属性値

o背景色
パッケージのプロパティ・要求のプロパティの各タブ（概要・詳細・ユーザ定義属性・説明・属性）・属性（複数編集）で変更を行った属性値の背景色


Enterprise Architectとの連携

ページ位置:

Enterprise Architectとの連携

ここでは、以下について説明いたします。

·要求選択アドイン

·Enterprise Architectの用語集アドイン機能

·RaQuestのオブジェクトとEnterprise Architectのオブジェクトとの関係

·Enterprise ArchitectでRaQuestの情報の参照方法


要求選択アドイン/EA要求選択ツール

ページ位置: Enterprise Architectとの連携 >

要求選択アドイン/EA要求選択ツール

RaQuest要求選択アドイン・EA要求選択ツールを使うことで、RaQuestとEnterprise Architectの連携がより楽に行うことができるようになります。

RaQuest要求選択アドイン

インストール時に「RaQuest要求選択アドイン」をインストールするように設定した場合、Enterprise Architect で選択している要求をRaQuestで選択状態にするためのツールがインストールされ、Enterprise Architectのアドイン・拡張リボンに「RaQuest要求選択オプション」とEnterprise Architectで要素を選択した時のコンテキストメニューのアドイン・拡張に「RaQuest要求選択」が追加されます。

同じPC上で、同じプロジェクトを開いているRaQuestがある場合に、Enterprise Architectで要求を選択し、コンテキストメニューのアドイン・拡張の「RaQuest要求選択」メニューを選択すると、Enterprise Architectで選択している要求と同じ要求を RaQuestで、選択状態にします。

選択に失敗しても、成功してもメッセージは表示しません

EA要求選択ツール

インストール時に「EA要求選択ツール」をインストールするように設定した場合、RaQuest で選択している要求を Enterprise Architectのモデルブラウザで選択状態にするためのツールがインストールされ、RaQuestのツールメニューに「EA要素選択」が追加されています。

同じPC上で、同じプロジェクトを開いているEnterprise Architectがある場合に、RaQuestで要求を選択し、「EA要素選択」メニューを選択すると、RaQuestで選択している要求と同じ要求を Enterprise Architectのモデルブラウザで、選択状態にします。

選択に失敗しても、成功してもメッセージは表示しません


Enterprise Architectの用語集アドイン機能

ページ位置: Enterprise Architectとの連携 >

Enterprise Architectの用語集アドイン機能

Enterprise Architectのアドイン・拡張メニューから用語集を選択することで、RaQuest と同じ形式で用語集を参照できます。

ダイアグラムを開き、一つの要素を選択し、「用語を選択した要素の設定」を選ぶことで、要素に用語集から用語を設定できます。

「レポート出力」ボタンで、用語集の出力を行うことができます。


Enterprise Architectオブジェクトとの関係

ページ位置: Enterprise Architectとの連携 >

Enterprise Architectオブジェクトとの関係

ここでは、RaQuestのオブジェクトがどのようにEnterprise Architectのオブジェクトと関連しているかを記述します。

それぞれ以下の対応で RaQuestのオブジェクトは Enterprise Architectのプロジェクトに保存されています。

RaQuest オブジェクト | Enterprise Architect オブジェクト | 備考
要求 | 要求 |
変更要求 | 要求 |
要求の属性 | 要求のプロパティまたは、タグ付き値 |
ユーザ定義属性 | 要求のタグ付き値 |
要求間の関連 | 要求間の依存関係線 |
パッケージ | パッケージ |
コメント | 要求とノートリンクで結ばれたノート | 公開にチェックが入れられたコメントは要素の問題点にも格納
資料 | 要求のファイル |
担当者 | 既定値（メンバー・担当者） | 参考：担当者
割り当てられた担当者 | 要求の担当者の割り当て | 参考：担当者
要求とユースケース関連 | 要求とユースケースの実現関係線 |
要求とUML要素の関連付け | 要求と要素の実現関係線 | ダイアグラム・属性・操作との関係は要求のファイルとして格納
テスト項目 | 要求に割り当てられたテスト項目 |
全体の自動ID | 種類要求の自動カウンター | 適用・非適用も同期
ログインユーザ名 | ユーザーオプションの作者 | 参考：ログインユーザ名
要求の種類 | 既定値（要求） | 参考：要求の種類 順番はEnterprise Architectでは非保存
要求の状態 | 既定値（状態） | 参考：要求の状態 順番はEnterprise Architectでは非保存

上記のようになっているため、要求の更新履歴を除いた、要求のほとんどの情報を Enterprise Architect から参照できます。参照の方法についてはEnterprise ArchitectでのRaQuestの情報の参照方法を参照ください。


ログインユーザー名

ページ位置: Enterprise Architectとの連携 > Enterprise Architectオブジェクトとの関係 >

ログインユーザー名

ユーザー名の設定はEnterprise Architectと共通になっています。

Enterprise Architectで設定する場合は以下のように確認してください。

「デスクトップ版」「プロフェッショナル版」「コーポレート版以上でセキュリティが無効」の場合

1.Enterprise Architectを起動します。

2.ホームリボン | 設定 | オプション | ユーザー を選択します。

3.「ユーザーのオプション」ダイアログが表示されますので、「全般」の「作者」の欄を確認します。必要ならば名前を入力し変更してください。

「コーポレート版以上でセキュリティが有効」の場合

1.Enterprise Architectを起動し、対象プロジェクトファイルを読み込みます。

2.ログイン画面が表示されます。

3.admin でログインします。

4.プロジェクトリボン | セキュリティ | ユーザー でユーザーの管理画面を表示します。

5.「ユーザーの管理」画面でユーザーを確認してください。必要に応じ新規ユーザーを追加してください。

6.RaQuest の全機能を使うためには、以下のアクセス権が必要です。

oロックの参照

oダイアグラムの作成と削除

oドキュメントの生成

oXMIの読み込み

oXMIの出力

o要素・接続・パッケージの編集と削除

o要素のロック

oダイアグラムの編集

oリファレンス情報の管理（必須ではない。付与しない場合、RaQuestでプロジェクトオプションが変更不可）

「コーポレート版以上でセキュリティが有効」のプロジェクトファイルを読み込むと読み込み時にログインダイアログが表示されます。登録したユーザ名、パスワードを入力してください。


Enterprise Architectにおける要求の種類

ページ位置: Enterprise Architectとの連携 > Enterprise Architectオブジェクトとの関係 >

Enterprise Architectにおける要求の種類

RaQuest の要求の種類は Enterprise Architectの状態と同期しています。ですので、RaQuest でも、Enterprise Architectでも設定が可能です。

RaQuest での設定は、要求の種類の設定を参照してください。

Enterprise Architectでの設定は、プロジェクトファイルを開いた後で、プロジェクトリボン | リファレンス情報 | 既定値 | 既定値 と選択して「既定値」ダイアログを表示させ、「要求」グループで設定してください。


Enterprise Architectにおける要求の状態

ページ位置: Enterprise Architectとの連携 > Enterprise Architectオブジェクトとの関係 >

Enterprise Architectにおける要求の状態

RaQuest の要求の状態は Enterprise Architectの状態と同期しています。ですので、RaQuest でも、Enterprise Architectでも設定が可能です。

RaQuest での設定は、要求の状態の設定を参照してください。

Enterprise Architectでの設定は、プロジェクトファイルを開いた後で、プロジェクトリボン | リファレンス情報 | 既定値 | 既定値 と選択して「既定値」ダイアログを表示させ、「状態」グループで設定してください。


Enterprise ArchitectでRaQuestの情報の参照方法

ページ位置: Enterprise Architectとの連携 >

Enterprise ArchitectでRaQuestの情報の参照方法

RaQuestで設定した属性・資料等は更新履歴・部署などの一部の情報を除き、Enterprise Architectから参照可能です。それぞれ下記手順で参照してください。

·担当者
プロジェクトリボン | リファレンス情報 | 既定値 | メンバー | 担当者

·要求に割り当てた担当者
ホームリボン | 画面 | 設計支援 | 担当者の割り当て で表示される「担当者の割り当て」サブウィンドウ

·資料
要求のプロパティのファイルグループ

·要求の属性
要求のプロパティまたは、タグ付き値

·テスト項目
ホームリボン | 画面 | 設計支援 | テストの概要 で表示される「テスト項目」サブウィンドウ

·要求間の関連
ホームリボン | 画面 | 設計 | 追跡 で表示される「トレーサビリティ」サブウィンドウ


現在の制限事項

ページ位置: その他 >

現在の制限事項

現在のバージョンには以下のような制限事項がございます。

·メニュー項目説明の中の項目やオプションの説明の中の項目に(現ビルドでは未提供機能)と明記している項目
これらの項目は、将来修正あるいは改善することを検討しています。

·リポジトリとしてSQL Serverなどをご利用の場合に、初回設定後に限り、RaQuestの終了時に以下のメッセージがRaQuest のウインドウの裏に表示される場合があります。

この場合には、RaQuestがロックされてこのメッセージに答えることができなくなり、強制終了する以外の方法がありません。これを避けるためには、Enterprise Architectのユーザーのオプションの振る舞いグループで設定できる、「自動的に変更を保存」のチェックをいれてください。


以前のバージョンのプロジェクトの利用

ページ位置: その他 >

以前のバージョンのプロジェクトの利用

·RaQuestの以前のバージョンで利用したプロジェクトを開くと「プロジェクトを開けません。古いデータ格納形式のため）」（下図）のダイアログが表示される場合があります。
61
バージョン4.5以降のRaQuestでは、該当プロジェクトを開くことはできません。バージョン4.4以前のRaQuestで、該当のプロジェクトを開き、データ格納形式のアップデートを行ってください。

·拡張子rqeのファイルを、EA16以降との組み合わせで開くと「EAバージョン16以降との組み合わせでは、rqeファイルは開けません。拡張子をeapxに変更してください。」（下図）と表示します。
156
該当のプロジェクトファイルの拡張子をrqeからeapxに変更し、ご利用ください。


「SysMLデータプロジェクトへの変更確認」ダイアログ

ページ位置: その他 >

「SysMLデータプロジェクトへの変更確認」ダイアログ

SysMLデータプロジェクトへの変更確認する時の確認ダイアログです。

SysMLデータプロジェクトに変更する際に、以下の変更を行います。

·要求の種類として、SysMLの種類を追加

·要求の種類の既定値として「要求」を設定

·text タグ付き値の値を要求詳細となるように変更

·id タグ付き値を要求IDとなるように変更

·RaQuestバージョン4.0以前で開けないように変更

·オプション「IDを概要の前に付与して保存」を無効に変更し、変更できないように設定

·オプション「要求の詳細欄で拡張書式を利用」を無効に変更し、変更できないように設定

·オプション「要求を別の要求の下に作成したときに、自動的に関係を作成」を有効に変更し、変更できないように設定

·オプション「作成する関係の種類を指定」を有効に変更・種類を「ネスト」(包含線)に変更し、変更できないように設定

SysMLデータプロジェクトにおける動作は、SysMLデータプロジェクトをご覧ください。